# CVE-2026-30898: Apache Airflow: Bad example of BashOperator shell injection via dag_run.conf

> Users who copied a flawed documentation example for BashOperator may allow attackers to execute arbitrary code on workers via unsanitized DAG run configurations.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2026
- **Updated:** 22 Apr 2026
- **Also known as:** BIT-airflow-2026-30898, GHSA-6337-2587-f2jq

## What is CVE-2026-30898?

CVE-2026-30898 is a high-severity command injection vulnerability in Apache Airflow, published on 18 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An example of BashOperator in Airflow documentation suggested a way of passing dag_run.conf in the way that could cause unsanitized user input to be used to escalate privileges of UI user to allow execute code on worker. Users should review if any of their own DAGs have adopted this incorrect advice.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2026-30898?

1 open source package ship an affected version, including airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `airflow` | Bitnami | All versions | 3.2.0 |

Products: Apache Airflow.

## How do I fix CVE-2026-30898?

Upgrade airflow to 3.2.0 or later.

## Is CVE-2026-30898 being exploited?

There is no known exploitation of CVE-2026-30898 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30898 and fix it if it is affected.

What it is: CVE-2026-30898 is a high-severity command injection vulnerability in Apache Airflow, published on 18 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-30898 in the wild and no public exploit code.

Affected packages and fixed versions:
- airflow (Bitnami): affected all versions; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30898/ (Markdown: https://insights.sbomify.com/CVE-2026-30898/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30898
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30898
- OSV: https://osv.dev/vulnerability/CVE-2026-30898

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30898/
Summaries are generated and may contain mistakes; the official description above is the record.
