# CVE-2026-30912: Apache Airflow: Exposing stack trace in case of constraint error

> Apache Airflow exposes stack traces in API responses during SQL errors, potentially leaking sensitive information to attackers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2026
- **Updated:** 20 Apr 2026
- **Also known as:** BIT-airflow-2026-30912, ECHO-5166-3541-6abf, GHSA-w7cf-2pmc-5m4c, MINI-r52m-h5pv-78mw, PYSEC-2026-18, PYSEC-2026-2361

## What is CVE-2026-30912?

CVE-2026-30912 is a high-severity vulnerability in Apache Airflow, published on 18 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In case of SQL errors, exception/stack trace of errors was exposed in API even if "api/expose_stack_traces" was set to false. That could lead to exposing additional information to potential attacker. Users are recommended to upgrade to Apache Airflow 3.2.0, which fixes the issue.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2026-30912?

5 open source packages ship an affected version, including apache-airflow-core, airflow and apache-airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-core` | PyPI | All versions | 3.2.0 |
| `apache-airflow-core` | PyPI | All versions | 3.2.0 |
| `apache-airflow-core` | PyPI | All versions | 3.2.0 |
| `airflow` | Bitnami | All versions | 3.2.0 |
| `apache-airflow` | PyPI | All versions | 3.2.0 |

Products: Apache Airflow.

## How do I fix CVE-2026-30912?

Upgrade apache-airflow-core to 3.2.0 or later.

## Is CVE-2026-30912 being exploited?

There is no known exploitation of CVE-2026-30912 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30912 and fix it if it is affected.

What it is: CVE-2026-30912 is a high-severity vulnerability in Apache Airflow, published on 18 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-30912 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-core (PyPI): affected all versions; fixed in 3.2.0
- apache-airflow-core (PyPI): affected all versions; fixed in 3.2.0
- apache-airflow-core (PyPI): affected all versions; fixed in 3.2.0
- airflow (Bitnami): affected all versions; fixed in 3.2.0
- apache-airflow (PyPI): affected all versions; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30912/ (Markdown: https://insights.sbomify.com/CVE-2026-30912/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30912
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30912
- OSV: https://osv.dev/vulnerability/CVE-2026-30912

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30912/
Summaries are generated and may contain mistakes; the official description above is the record.
