# CVE-2026-30917: Stored XSS on Bucket namespace pages

> Attackers can inject malicious scripts into Bucket table fields, executing them when users view namespace pages in MediaWiki.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:L/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Mar 2026
- **Updated:** 10 Mar 2026
- **Also known as:** GHSA-8jrp-37wc-5v7c

## What is CVE-2026-30917?

CVE-2026-30917 is a high-severity cross-site scripting vulnerability in weirdgloop mediawiki-extensions-Bucket, published on 9 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Bucket is a MediaWiki extension to store and retrieve structured data on articles. Prior to 2.1.1, a stored XSS can be inserted into any Bucket table field that has a PAGE type, which will execute whenever a user views that table's corresponding Bucket namespace page. This vulnerability is fixed in 2.1.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-30917?


## How do I fix CVE-2026-30917?

No fix has been published for CVE-2026-30917 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-30917 being exploited?

There is no known exploitation of CVE-2026-30917 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30917 and fix it if it is affected.

What it is: CVE-2026-30917 is a high-severity cross-site scripting vulnerability in weirdgloop mediawiki-extensions-Bucket, published on 9 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-30917 in the wild and no public exploit code.

Affected product: weirdgloop mediawiki-extensions-Bucket. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30917/ (Markdown: https://insights.sbomify.com/CVE-2026-30917/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30917
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30917
- OSV: https://osv.dev/vulnerability/CVE-2026-30917

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30917/
Summaries are generated and may contain mistakes; the official description above is the record.
