{"answers":{"affected":"3 open source packages ship an affected version, including github.com/autobrr/qui. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-30924 in the wild and no public exploit code.","fix":"Upgrade github.com/autobrr/qui to 1.15.0 or later.","what":"CVE-2026-30924 is a critical vulnerability in autobrr qui, published on 19 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-30924 and fix it if it is affected.\n\nWhat it is: CVE-2026-30924 is a critical vulnerability in autobrr qui, published on 19 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-30924 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/autobrr/qui (Go): affected all versions; no fix listed\n- github.com/autobrr/qui (Go): affected all versions; fixed in 1.15.0\n- github.com/autobrr/qui (Go): affected all versions; fixed in 1.15.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-30924/ (Markdown: https://insights.sbomify.com/CVE-2026-30924/index.md)","id":"CVE-2026-30924","markdown":"https://insights.sbomify.com/CVE-2026-30924/index.md","name":"CVE-2026-30924","record":{"aliases":["GHSA-h8vw-ph9r-xpch","GO-2026-4774","UBUNTU-CVE-2026-30924"],"analysis":{"component_type":"web_application","fix_type":"no_fix_stated","impacts":["data_read","code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"qBittorrent web interface","requires_auth":"none","summary":"Permissive CORS policy allows attackers to perform authenticated actions and exfiltrate data or execute code via social engineering.","user_interaction":"required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"qui","vendor":"getqui"}],"cvss":{"score":9,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:L/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-942","name":"Permissive Cross-domain Security Policy with Untrusted Domains"}],"description":"qui is a web interface for managing qBittorrent instances. Versions 1.14.1 and below use a permissive CORS policy that reflects arbitrary origins while also returning Access-Control-Allow-Credentials: true, effectively allowing any external webpage to make authenticated requests on behalf of a logged-in user. An attacker can exploit this by tricking a victim into loading a malicious webpage, which silently interacts with the application using the victim's session and potentially exfiltrating sensitive data such as API keys and account credentials, or even achieving full system compromise through the built-in External Programs manager. Exploitation requires that the victim access the application via a non-localhost hostname and load an attacker-controlled webpage, making highly targeted social-engineering attacks the most likely real-world scenario. This issue was not fixed at the time of publication.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"qui CORS Misconfiguration: Arbitrary Origins Trusted","id":"CVE-2026-30924","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"misconfiguration","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"Parse Server affected by Regular Expression Denial of Service (ReDoS) via `$regex` query in LiveQuery","id":"CVE-2026-30925"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/autobrr/qui","purl":"pkg:golang/github.com/autobrr/qui","source":"GO-2026-4774"},{"ecosystem":"Go","fixed":["1.15.0"],"introduced":["0"],"last_affected":[],"package":"github.com/autobrr/qui","purl":null,"source":"GHSA-h8vw-ph9r-xpch"},{"ecosystem":"Go","fixed":["1.15.0"],"introduced":["0"],"last_affected":[],"package":"github.com/autobrr/qui","purl":"pkg:golang/github.com/autobrr/qui","source":"GHSA-h8vw-ph9r-xpch"}],"prev":{"headline":"libModSecurity3 denial of service via segfault when using t:hexDecode on single-character query strings","id":"CVE-2026-30923"},"products":["qui"],"published":"2026-03-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-20","vendors":["autobrr"]},"summary":"Permissive CORS policy allows attackers to perform authenticated actions and exfiltrate data or execute code via social engineering.","url":"https://insights.sbomify.com/CVE-2026-30924/"}