# CVE-2026-30924: qui CORS Misconfiguration: Arbitrary Origins Trusted

> Permissive CORS policy allows attackers to perform authenticated actions and exfiltrate data or execute code via social engineering.

- **Severity:** Critical 9.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:L/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Mar 2026
- **Updated:** 20 Mar 2026
- **Also known as:** GHSA-h8vw-ph9r-xpch, GO-2026-4774, UBUNTU-CVE-2026-30924

## What is CVE-2026-30924?

CVE-2026-30924 is a critical vulnerability in autobrr qui, published on 19 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

qui is a web interface for managing qBittorrent instances. Versions 1.14.1 and below use a permissive CORS policy that reflects arbitrary origins while also returning Access-Control-Allow-Credentials: true, effectively allowing any external webpage to make authenticated requests on behalf of a logged-in user. An attacker can exploit this by tricking a victim into loading a malicious webpage, which silently interacts with the application using the victim's session and potentially exfiltrating sensitive data such as API keys and account credentials, or even achieving full system compromise through the built-in External Programs manager. Exploitation requires that the victim access the application via a non-localhost hostname and load an attacker-controlled webpage, making highly targeted social-engineering attacks the most likely real-world scenario. This issue was not fixed at the time of publication.

Weakness: CWE-942 (Permissive Cross-domain Security Policy with Untrusted Domains)

## Which versions are affected by CVE-2026-30924?

3 open source packages ship an affected version, including github.com/autobrr/qui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/autobrr/qui` | Go | All versions | None |
| `github.com/autobrr/qui` | Go | All versions | 1.15.0 |
| `github.com/autobrr/qui` | Go | All versions | 1.15.0 |

Products: Getqui Qui.

## How do I fix CVE-2026-30924?

Upgrade github.com/autobrr/qui to 1.15.0 or later.

## Is CVE-2026-30924 being exploited?

There is no known exploitation of CVE-2026-30924 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30924 and fix it if it is affected.

What it is: CVE-2026-30924 is a critical vulnerability in autobrr qui, published on 19 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-30924 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/autobrr/qui (Go): affected all versions; no fix listed
- github.com/autobrr/qui (Go): affected all versions; fixed in 1.15.0
- github.com/autobrr/qui (Go): affected all versions; fixed in 1.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30924/ (Markdown: https://insights.sbomify.com/CVE-2026-30924/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30924
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30924
- OSV: https://osv.dev/vulnerability/CVE-2026-30924

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30924/
Summaries are generated and may contain mistakes; the official description above is the record.
