CVE-2026-30925 Parse Server affected by Regular Expression Denial of Service (ReDoS) via `$regex` query in LiveQuery
Attackers can crash Parse Server by sending crafted regex patterns in LiveQuery subscriptions, blocking the event loop and making the service unresponsive.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-30925?
CVE-2026-30925 is a high-severity denial of service vulnerability in Parseplatform Parse-Server, published on 9 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.0-alpha.14 and 8.6.11, a malicious client can subscribe to a LiveQuery with a crafted $regex pattern that causes catastrophic backtracking, blocking the Node.js event loop. This makes the entire Parse Server unresponsive, affecting all clients. Any Parse Server deployment with LiveQuery enabled is affected. The attacker only needs the application ID and JavaScript key, both of which are public in client-side apps. This only affects LiveQuery subscription matching, which evaluates regex in JavaScript on the Node.js event loop. Normal REST and GraphQL queries are not affected because their regex is evaluated by the database engine. This vulnerability is fixed in 9.5.0-alpha.14 and 8.6.11.
Weakness: CWE-1333
Which versions are affected by CVE-2026-30925?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.11 |
parse-server npm | All versions | 8.6.11 |
parse-server npm | From 9.0.0-alpha.1 | 9.5.0-alpha.14 |
parse-server npm | From 9.0.0-alpha.1 | 9.5.0-alpha.14 |
parse Bitnami | All versions | 8.6.11, 9.5.0 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2026-30925?
Upgrade parse-server to a fixed version for your release line: 8.6.11 or 9.5.0-alpha.14.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-30925 being exploited?
There is no known exploitation of CVE-2026-30925 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
Sources
Also known as BIT-parse-2026-30925, GHSA-mf3j-86qx-cq5j.