# CVE-2026-30928: Glances Exposes Unauthenticated Configuration Secrets

> Unauthenticated attackers can access sensitive configuration secrets like passwords and API tokens via the Glances API endpoint.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 10 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-30928, GHSA-gh4x-f7cq-wwx6, PYSEC-2026-2164, UBUNTU-CVE-2026-30928

## What is CVE-2026-30928?

CVE-2026-30928 is a high-severity vulnerability in nicolargo glances, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Glances is an open-source system cross-platform monitoring tool. Prior to 4.5.1, the /api/4/config REST API endpoint returns the entire parsed Glances configuration file (glances.conf) via self.config.as_dict() with no filtering of sensitive values. The configuration file contains credentials for all configured backend services including database passwords, API tokens, JWT signing keys, and SSL key passwords. This vulnerability is fixed in 4.5.1.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-30928?

3 open source packages ship an affected version, including glances and Glances. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glances` | PyPI | All versions | 4.5.1 |
| `glances` | PyPI | All versions | 4.5.1 |
| `Glances` | PyPI | All versions | 4.5.1 |

Products: Nicolargo Glances.

## How do I fix CVE-2026-30928?

Upgrade glances to 4.5.1 or later.

## Is CVE-2026-30928 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30928 exists.

Public exploit code:

- Glances - Information Disclosure (nuclei): http/cves/2026/CVE-2026-30928.yaml

## Other vulnerabilities in nicolargo glances

- [CVE-2026-32633](https://insights.sbomify.com/CVE-2026-32633/): Glances's Browser API Exposes Reusable Downstream Credentials via `/api/4/serverslist` (critical 9.1)
- [CVE-2026-32596](https://insights.sbomify.com/CVE-2026-32596/): Glances exposes the REST API without authentication (high 8.7)
- [CVE-2026-32610](https://insights.sbomify.com/CVE-2026-32610/): Glances's Default CORS Configuration Allows Cross-Origin Credential Theft (high 8.1)
- [CVE-2026-32634](https://insights.sbomify.com/CVE-2026-32634/): Glances Central Browser Autodiscovery Leaks Reusable Credentials to Zeroconf-Spoofed Servers (high 8.1)
- [CVE-2026-33641](https://insights.sbomify.com/CVE-2026-33641/): Glances Vulnerable to Command Injection via Dynamic Configuration Values (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30928 and fix it if it is affected.

What it is: CVE-2026-30928 is a high-severity vulnerability in nicolargo glances, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30928 exists.

Affected packages and fixed versions:
- glances (PyPI): affected all versions; fixed in 4.5.1
- glances (PyPI): affected all versions; fixed in 4.5.1
- Glances (PyPI): affected all versions; fixed in 4.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30928/ (Markdown: https://insights.sbomify.com/CVE-2026-30928/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30928
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30928
- OSV: https://osv.dev/vulnerability/CVE-2026-30928

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30928/
Summaries are generated and may contain mistakes; the official description above is the record.
