CVE-2026-30938 Parse Server has denylist `requestKeywordDenylist` keyword scan bypass through nested object placement

Medium 6.9 Published Updated

Attackers can bypass the default requestKeywordDenylist security control in Parse Server by placing nested objects before prohibited keywords, allowing restricted data submission.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-30938?

CVE-2026-30938 is a medium-severity vulnerability in Parseplatform Parse-Server, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 8.6.12 and 9.5.1-alpha.1, the requestKeywordDenylist security control can be bypassed by placing any nested object or array before a prohibited keyword in the request payload. This is caused by a logic bug that stops scanning sibling keys after encountering the first nested value. Any custom requestKeywordDenylist entries configured by the developer are equally by-passable using the same technique. All Parse Server deployments are affected. The requestKeywordDenylist is enabled by default. This vulnerability is fixed in 8.6.12 and 9.5.1-alpha.1. Use a Cloud Code beforeSave trigger to validate incoming data for prohibited keywords across all classes.

Weakness: CWE-693

Which versions are affected by CVE-2026-30938?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.

PackageAffectedFixed in
parse-server npmAll versions8.6.12
parse-server npmAll versions8.6.12
parse-server npmFrom 9.0.0-alpha.19.5.1-alpha.1
parse-server npmFrom 9.0.0-alpha.19.5.1-alpha.1
parse BitnamiAll versions8.6.12, 9.5.1

Products include Parseplatform Parse-Server.

How do I fix CVE-2026-30938?

Upgrade parse-server to a fixed version for your release line: 8.6.12 or 9.5.1-alpha.1.

Is CVE-2026-30938 being exploited?

There is no known exploitation of CVE-2026-30938 in the wild and no public exploit code.

All Parseplatform Parse-Server vulnerabilities

Sources

Also known as BIT-parse-2026-30938, GHSA-q342-9w2p-57fp.

Is CVE-2026-30938 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free