CVE-2026-30941 Parse Server has a NoSQL injection via token type in password reset and email verification endpoints
Unauthenticated attackers can inject MongoDB operators to extract password reset and email verification tokens, potentially taking over accounts.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-30941?
CVE-2026-30941 is a high-severity SQL injection vulnerability in Parseplatform Parse-Server, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 8.6.14 and 9.5.2-alpha.1, NoSQL injection vulnerability allows an unauthenticated attacker to inject MongoDB query operators via the token field in the password reset and email verification resend endpoints. The token value is passed to database queries without type validation and can be used to extract password reset and email verification tokens. Any Parse Server deployment using MongoDB with email verification or password reset enabled is affected. When emailVerifyTokenReuseIfValid is configured, the email verification token can be fully extracted and used to verify a user's email address without inbox access. This vulnerability is fixed in 8.6.14 and 9.5.2-alpha.1.
Weakness: CWE-943
Which versions are affected by CVE-2026-30941?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.14 |
parse-server npm | All versions | 8.6.14 |
parse-server npm | From 9.0.0 | 9.5.2-alpha.1 |
parse-server npm | From 9.0.0 | 9.5.2-alpha.1 |
parse Bitnami | All versions | 8.6.14, 9.5.2 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2026-30941?
Upgrade parse-server to a fixed version for your release line: 8.6.14 or 9.5.2-alpha.1.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2026-30941 being exploited?
There is no known exploitation of CVE-2026-30941 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
Sources
Also known as BIT-parse-2026-30941, GHSA-vgjh-hmwf-c588.