CVE-2026-30948 Parse Server has stored cross-site scripting (XSS) via SVG file upload
Authenticated users can upload malicious SVG files to execute scripts in the browser, stealing session tokens and taking over accounts.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-30948?
CVE-2026-30948 is a high-severity cross-site scripting vulnerability in Parseplatform Parse-Server, published on 10 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.4 and 8.6.17, a stored cross-site scripting (XSS) vulnerability allows any authenticated user to upload an SVG file containing JavaScript. The file is served inline with Content-Type: image/svg+xml and without protective headers, causing the browser to execute embedded scripts in the Parse Server origin. This can be exploited to steal session tokens from localStorage and achieve account takeover. The default fileExtensions option blocks HTML file extensions but does not block SVG, which is a well-known XSS vector. All Parse Server deployments where file upload is enabled for authenticated users (the default) are affected. This vulnerability is fixed in 9.5.2-alpha.4 and 8.6.17.
Weakness: CWE-79
Which versions are affected by CVE-2026-30948?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.17 |
parse-server npm | All versions | 8.6.17 |
parse-server npm | From 9.0.0 | 9.5.2-alpha.4 |
parse-server npm | From 9.0.0 | 9.5.2-alpha.4 |
parse Bitnami | All versions | 8.6.17, 9.5.2 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2026-30948?
Upgrade parse-server to a fixed version for your release line: 8.6.17 or 9.5.2-alpha.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-30948 being exploited?
There is no known exploitation of CVE-2026-30948 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
Sources
Also known as BIT-parse-2026-30948, GHSA-hcj7-6gxh-24ww.