# CVE-2026-30948: Parse Server has stored cross-site scripting (XSS) via SVG file upload

> Authenticated users can upload malicious SVG files to execute scripts in the browser, stealing session tokens and taking over accounts.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:N/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 10 Mar 2026
- **Also known as:** BIT-parse-2026-30948, GHSA-hcj7-6gxh-24ww

## What is CVE-2026-30948?

CVE-2026-30948 is a high-severity cross-site scripting vulnerability in Parseplatform Parse-Server, published on 10 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.4 and 8.6.17, a stored cross-site scripting (XSS) vulnerability allows any authenticated user to upload an SVG file containing JavaScript. The file is served inline with Content-Type: image/svg+xml and without protective headers, causing the browser to execute embedded scripts in the Parse Server origin. This can be exploited to steal session tokens from localStorage and achieve account takeover. The default fileExtensions option blocks HTML file extensions but does not block SVG, which is a well-known XSS vector. All Parse Server deployments where file upload is enabled for authenticated users (the default) are affected. This vulnerability is fixed in 9.5.2-alpha.4 and 8.6.17.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-30948?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 8.6.17 |
| `parse-server` | npm | All versions | 8.6.17 |
| `parse-server` | npm | From 9.0.0 | 9.5.2-alpha.4 |
| `parse-server` | npm | From 9.0.0 | 9.5.2-alpha.4 |
| `parse` | Bitnami | All versions | 8.6.17, 9.5.2 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2026-30948?

Upgrade parse-server to a fixed version for your release line: 8.6.17 or 9.5.2-alpha.4.

## Is CVE-2026-30948 being exploited?

There is no known exploitation of CVE-2026-30948 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30948 and fix it if it is affected.

What it is: CVE-2026-30948 is a high-severity cross-site scripting vulnerability in Parseplatform Parse-Server, published on 10 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-30948 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 8.6.17
- parse-server (npm): affected all versions; fixed in 8.6.17
- parse-server (npm): affected from 9.0.0; fixed in 9.5.2-alpha.4
- parse-server (npm): affected from 9.0.0; fixed in 9.5.2-alpha.4
- parse (Bitnami): affected all versions; fixed in 8.6.17, 9.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30948/ (Markdown: https://insights.sbomify.com/CVE-2026-30948/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30948
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30948
- OSV: https://osv.dev/vulnerability/CVE-2026-30948

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30948/
Summaries are generated and may contain mistakes; the official description above is the record.
