# CVE-2026-30949: Parse Server is missing audience validation in Keycloak authentication adapter

> Attackers can authenticate as any user by using a valid token from a different client application in multi-client Keycloak realms.

- **Severity:** High 7.6 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 10 Mar 2026
- **Also known as:** BIT-parse-2026-30949, GHSA-48mh-j4p5-7j9v

## What is CVE-2026-30949?

CVE-2026-30949 is a high-severity authentication bypass vulnerability in Parseplatform Parse-Server, published on 10 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.5 and 8.6.18, the Keycloak authentication adapter does not validate the azp (authorized party) claim of Keycloak access tokens against the configured client-id. A valid access token issued by the same Keycloak realm for a different client application can be used to authenticate as any user on the Parse Server that uses the Keycloak adapter. This enables cross-application account takeover in multi-client Keycloak realms. All Parse Server deployments that use the Keycloak authentication adapter with a Keycloak realm that has multiple client applications are affected. This vulnerability is fixed in 9.5.2-alpha.5 and 8.6.18.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-30949?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 8.6.18 |
| `parse-server` | npm | All versions | 8.6.18 |
| `parse-server` | npm | From 9.0.0 | 9.5.2-alpha.5 |
| `parse-server` | npm | From 9.0.0 | 9.5.2-alpha.5 |
| `parse` | Bitnami | All versions | 8.6.18, 9.5.2 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2026-30949?

Upgrade parse-server to a fixed version for your release line: 8.6.18 or 9.5.2-alpha.5.

## Is CVE-2026-30949 being exploited?

There is no known exploitation of CVE-2026-30949 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30949 and fix it if it is affected.

What it is: CVE-2026-30949 is a high-severity authentication bypass vulnerability in Parseplatform Parse-Server, published on 10 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-30949 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 8.6.18
- parse-server (npm): affected all versions; fixed in 8.6.18
- parse-server (npm): affected from 9.0.0; fixed in 9.5.2-alpha.5
- parse-server (npm): affected from 9.0.0; fixed in 9.5.2-alpha.5
- parse (Bitnami): affected all versions; fixed in 8.6.18, 9.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30949/ (Markdown: https://insights.sbomify.com/CVE-2026-30949/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30949
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30949
- OSV: https://osv.dev/vulnerability/CVE-2026-30949

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30949/
Summaries are generated and may contain mistakes; the official description above is the record.
