# CVE-2026-30952: liquidjs has a path traversal fallback vulnerability

> Attackers can read arbitrary files via absolute paths in template tags, affecting applications using liquidjs with user-controlled templates.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 11 Mar 2026
- **Also known as:** CLEANSTART-2026-RV38622, GHSA-wmfp-5q7x-987x, MINI-7xxg-gj2x-5gpc, MINI-9jc9-fjmc-3q7f

## What is CVE-2026-30952?

CVE-2026-30952 is a high-severity path traversal vulnerability in harttle liquidjs, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

liquidjs is a Shopify / GitHub Pages compatible template engine in pure JavaScript. Prior to 10.25.0, the layout, render, and include tags allow arbitrary file access via absolute paths (either as string literals or through Liquid variables, the latter require dynamicPartials: true, which is the default). This poses a security risk when malicious users are allowed to control the template content or specify the filepath to be included as a Liquid variable. This vulnerability is fixed in 10.25.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-30952?

2 open source packages ship an affected version, including liquidjs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `liquidjs` | npm | All versions | 10.25.0 |
| `liquidjs` | npm | All versions | 10.25.0 |

Products: Liquidjs Liquidjs.

## How do I fix CVE-2026-30952?

Upgrade liquidjs to 10.25.0 or later.

## Is CVE-2026-30952 being exploited?

There is no known exploitation of CVE-2026-30952 in the wild and no public exploit code.

Public exploit code:

- PoC for CVE-2026-30952: Path Traversal vulnerability in liquidjs via absolute paths in layout, render, and include tags. (github_poc): https://github.com/MorielHarush/CVE-2026-30952-PoC

## Other vulnerabilities in harttle liquidjs

- [CVE-2026-35525](https://insights.sbomify.com/CVE-2026-35525/): LiquidJS has a root restriction bypass for partial and layout loading through symlinked templates (high 8.2)
- [CVE-2026-41311](https://insights.sbomify.com/CVE-2026-41311/): LiquidJS is vulnerable to Denial of Service via circular block reference in layout (high 7.5)
- [CVE-2026-33285](https://insights.sbomify.com/CVE-2026-33285/): LiquidJS: memoryLimit Bypass through Negative Range Values Leads to Process Crash (high 7.5)
- [CVE-2026-33287](https://insights.sbomify.com/CVE-2026-33287/): LiquidJS has Exponential Memory Amplification through its replace_first Filter $& Pattern (high 7.5)
- [CVE-2026-39859](https://insights.sbomify.com/CVE-2026-39859/): LiquidJS has a renderFile() / parseFile() bypass configured root and allow arbitrary file read (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30952 and fix it if it is affected.

What it is: CVE-2026-30952 is a high-severity path traversal vulnerability in harttle liquidjs, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-30952 in the wild and no public exploit code.

Affected packages and fixed versions:
- liquidjs (npm): affected all versions; fixed in 10.25.0
- liquidjs (npm): affected all versions; fixed in 10.25.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30952/ (Markdown: https://insights.sbomify.com/CVE-2026-30952/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30952
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30952
- OSV: https://osv.dev/vulnerability/CVE-2026-30952

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30952/
Summaries are generated and may contain mistakes; the official description above is the record.
