# CVE-2026-30960: RSSN has Arbitrary Code Execution via Unvalidated JIT Instruction Generation in C-FFI Interface

> Attackers can execute arbitrary code via malicious inputs in the JIT engine exposed through the C-FFI interface in the rssn library.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 10 Mar 2026
- **Also known as:** GHSA-9c4h-pwmf-m6fj, RUSTSEC-2026-0038

## What is CVE-2026-30960?

CVE-2026-30960 is a critical code injection vulnerability in Apich-Organization rssn, published on 10 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

rssn is a scientific computing library for Rust, combining a high-performance symbolic computation engine with numerical methods support and physics simulations functionalities. The vulnerability exists in the JIT (Just-In-Time) compilation engine, which is fully exposed via the CFFI (Foreign Function Interface). Due to Improper Input Validation and External Control of Code Generation, an attacker can supply malicious parameters or instruction sequences through the CFFI layer. Since the library often operates with elevated privileges or within high-performance computing contexts, this allows for Arbitrary Code Execution (ACE) at the privilege level of the host process.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-754 (Improper Check for Unusual or Exceptional Conditions), CWE-695 (Use of Low-Level Functionality), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-30960?

3 open source packages ship an affected version, including rssn.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rssn` | crates.io | All versions | 0.2.9 |
| `rssn` | crates.io | All versions | 0.2.9 |
| `rssn` | crates.io | From 0.1.20 | 0.2.9 |

## How do I fix CVE-2026-30960?

Upgrade rssn to 0.2.9 or later.

## Is CVE-2026-30960 being exploited?

There is no known exploitation of CVE-2026-30960 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30960 and fix it if it is affected.

What it is: CVE-2026-30960 is a critical code injection vulnerability in Apich-Organization rssn, published on 10 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-30960 in the wild and no public exploit code.

Affected packages and fixed versions:
- rssn (crates.io): affected all versions; fixed in 0.2.9
- rssn (crates.io): affected all versions; fixed in 0.2.9
- rssn (crates.io): affected from 0.1.20; fixed in 0.2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30960/ (Markdown: https://insights.sbomify.com/CVE-2026-30960/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30960
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30960
- OSV: https://osv.dev/vulnerability/CVE-2026-30960

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30960/
Summaries are generated and may contain mistakes; the official description above is the record.
