CVE-2026-30962 Parse Server has a protected fields bypass via logical query operators
Authenticated users can bypass protected field restrictions using logical query operators to extract sensitive data from Parse Server deployments.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-30962?
CVE-2026-30962 is a high-severity missing authorization vulnerability in Parseplatform Parse-Server, published on 10 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.6 and 8.6.19, the validation for protected fields only checks top-level query keys. By wrapping a query constraint on a protected field inside a logical operator, the check is bypassed entirely. This allows any authenticated user to query on protected fields to extract field values. All Parse Server deployments have default protected fields and are vulnerable. This vulnerability is fixed in 9.5.2-alpha.6 and 8.6.19.
Weakness: CWE-284
Which versions are affected by CVE-2026-30962?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.19 |
parse-server npm | All versions | 8.6.19 |
parse-server npm | From 9.0.0 | 9.5.2-alpha.6 |
parse-server npm | From 9.0.0 | 9.5.2-alpha.6 |
parse Bitnami | All versions | 8.6.19, 9.5.2 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2026-30962?
Upgrade parse-server to a fixed version for your release line: 8.6.19 or 9.5.2-alpha.6.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-30962 being exploited?
There is no known exploitation of CVE-2026-30962 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
Sources
Also known as BIT-parse-2026-30962, GHSA-72hp-qff8-4pvv.