# CVE-2026-30964: Webauthn Framework: allowed_origins collapses URL-like origins to host-only values, bypassing exact origin validation

> Attackers can bypass WebAuthn origin validation by exploiting host-only matching, allowing unauthorized authentication if allowed_origins is configured.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 10 Mar 2026
- **Also known as:** GHSA-f7pm-6hr8-7ggm

## What is CVE-2026-30964?

CVE-2026-30964 is a medium-severity vulnerability in web-auth webauthn-framework, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

web-auth/webauthn-lib is an open source set of PHP libraries and a Symfony bundle to allow developers to integrate that authentication mechanism into their web applications. Prior to 5.2.4, when allowed_origins is configured, CheckAllowedOrigins reduces URL-like values to their host component and accepts on host match alone. This makes exact origin policies impossible to express: scheme and port differences are silently ignored. This vulnerability is fixed in 5.2.4.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-30964?

6 open source packages ship an affected version, including web-auth/webauthn-framework, web-auth/webauthn-lib and web-auth/webauthn-symfony-bundle. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `web-auth/webauthn-framework` | Packagist | From 5.2.0 | 5.2.4 |
| `web-auth/webauthn-framework` | Packagist | From 5.2.0 | 5.2.4 |
| `web-auth/webauthn-lib` | Packagist | From 5.2.0 | 5.2.4 |
| `web-auth/webauthn-lib` | Packagist | From 5.2.0 | 5.2.4 |
| `web-auth/webauthn-symfony-bundle` | Packagist | From 5.2.0 | 5.2.4 |
| `web-auth/webauthn-symfony-bundle` | Packagist | From 5.2.0 | 5.2.4 |

Products: Spomky-Labs Webauthn-Lib, Spomky-Labs Webauthn-Symfony-Bundle, Spomky-Labs Webauthn Framwork.

## How do I fix CVE-2026-30964?

Upgrade web-auth/webauthn-framework to 5.2.4 or later.

## Is CVE-2026-30964 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30964 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30964 and fix it if it is affected.

What it is: CVE-2026-30964 is a medium-severity vulnerability in web-auth webauthn-framework, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30964 exists.

Affected packages and fixed versions:
- web-auth/webauthn-framework (Packagist): affected from 5.2.0; fixed in 5.2.4
- web-auth/webauthn-framework (Packagist): affected from 5.2.0; fixed in 5.2.4
- web-auth/webauthn-lib (Packagist): affected from 5.2.0; fixed in 5.2.4
- web-auth/webauthn-lib (Packagist): affected from 5.2.0; fixed in 5.2.4
- web-auth/webauthn-symfony-bundle (Packagist): affected from 5.2.0; fixed in 5.2.4
- web-auth/webauthn-symfony-bundle (Packagist): affected from 5.2.0; fixed in 5.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30964/ (Markdown: https://insights.sbomify.com/CVE-2026-30964/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30964
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30964
- OSV: https://osv.dev/vulnerability/CVE-2026-30964

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30964/
Summaries are generated and may contain mistakes; the official description above is the record.
