# CVE-2026-30965: Parse Server session token exfiltration via `redirectClassNameForKey` query parameter

> Attackers can exfiltrate user session tokens via a query parameter, enabling account takeover in Parse Server deployments.

- **Severity:** Critical 9.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 11 Mar 2026
- **Also known as:** BIT-parse-2026-30965, GHSA-6r2j-cxgf-495f

## What is CVE-2026-30965?

CVE-2026-30965 is a critical vulnerability in Parseplatform Parse-Server, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.8 and 8.6.21, a vulnerability in Parse Server's query handling allows an authenticated or unauthenticated attacker to exfiltrate session tokens of other users by exploiting the redirectClassNameForKey query parameter. Exfiltrated session tokens can be used to take over user accounts. The vulnerability requires the attacker to be able to create or update an object with a new relation field, which depends on the Class-Level Permissions of at least one class. This vulnerability is fixed in 9.5.2-alpha.8 and 8.6.21.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-30965?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 8.6.21 |
| `parse-server` | npm | All versions | 8.6.21 |
| `parse-server` | npm | From 9.0.0-alpha.1 | 9.5.2-alpha.8 |
| `parse-server` | npm | From 9.0.0-alpha.1 | 9.5.2-alpha.8 |
| `parse` | Bitnami | All versions | 8.6.21, 9.5.2 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2026-30965?

Upgrade parse-server to a fixed version for your release line: 8.6.21 or 9.5.2-alpha.8.

## Is CVE-2026-30965 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30965 exists.

Public exploit code:

- Parse Server < 8.6.21 / 9.x < 9.5.2 - Session Token Exfiltration (nuclei): http/cves/2026/CVE-2026-30965.yaml

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)
- [CVE-2022-39396](https://insights.sbomify.com/CVE-2022-39396/): Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30965 and fix it if it is affected.

What it is: CVE-2026-30965 is a critical vulnerability in Parseplatform Parse-Server, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30965 exists.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 8.6.21
- parse-server (npm): affected all versions; fixed in 8.6.21
- parse-server (npm): affected from 9.0.0-alpha.1; fixed in 9.5.2-alpha.8
- parse-server (npm): affected from 9.0.0-alpha.1; fixed in 9.5.2-alpha.8
- parse (Bitnami): affected all versions; fixed in 8.6.21, 9.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30965/ (Markdown: https://insights.sbomify.com/CVE-2026-30965/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30965
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30965
- OSV: https://osv.dev/vulnerability/CVE-2026-30965

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30965/
Summaries are generated and may contain mistakes; the official description above is the record.
