CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
Attackers can escalate privileges and bypass access controls by directly modifying internal relationship tables via the API without a master key.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-30966?
CVE-2026-30966 is a critical vulnerability in Parseplatform Parse-Server, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.7 and 8.6.20, Parse Server's internal tables, which store Relation field mappings such as role memberships, can be directly accessed via the REST API or GraphQL API by any client using only the application key. No master key is required. An attacker can create, read, update, or delete records in any internal relationship table. Exploiting this allows the attacker to inject themselves into any Parse Role, gaining all permissions associated with that role, including full read, write, and delete access to classes protected by role-based Class-Level Permissions (CLP). Similarly, writing to any such table that backs a Relation field used in a pointerFields CLP bypasses that access control. This vulnerability is fixed in 9.5.2-alpha.7 and 8.6.20.
Weakness: CWE-284
Which versions are affected by CVE-2026-30966?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.20 |
parse-server npm | All versions | 8.6.20 |
parse-server npm | From 9.0.0-alpha.1 | 9.5.2-alpha.7 |
parse-server npm | From 9.0.0-alpha.1 | 9.5.2-alpha.7 |
parse Bitnami | All versions | 8.6.20, 9.5.2 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2026-30966?
Upgrade parse-server to a fixed version for your release line: 8.6.20 or 9.5.2-alpha.7.
Is CVE-2026-30966 being exploited?
There is no known exploitation of CVE-2026-30966 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
- CVE-2022-39396 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser
Sources
Also known as BIT-parse-2026-30966, GHSA-5f92-jrq3-28rc.