# CVE-2026-30966: Parse Server role escalation and CLP bypass via direct `_Join` table write

> Attackers can escalate privileges and bypass access controls by directly modifying internal relationship tables via the API without a master key.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 11 Mar 2026
- **Also known as:** BIT-parse-2026-30966, GHSA-5f92-jrq3-28rc

## What is CVE-2026-30966?

CVE-2026-30966 is a critical vulnerability in Parseplatform Parse-Server, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.7 and 8.6.20, Parse Server's internal tables, which store Relation field mappings such as role memberships, can be directly accessed via the REST API or GraphQL API by any client using only the application key. No master key is required. An attacker can create, read, update, or delete records in any internal relationship table. Exploiting this allows the attacker to inject themselves into any Parse Role, gaining all permissions associated with that role, including full read, write, and delete access to classes protected by role-based Class-Level Permissions (CLP). Similarly, writing to any such table that backs a Relation field used in a pointerFields CLP bypasses that access control. This vulnerability is fixed in 9.5.2-alpha.7 and 8.6.20.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-30966?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 8.6.20 |
| `parse-server` | npm | All versions | 8.6.20 |
| `parse-server` | npm | From 9.0.0-alpha.1 | 9.5.2-alpha.7 |
| `parse-server` | npm | From 9.0.0-alpha.1 | 9.5.2-alpha.7 |
| `parse` | Bitnami | All versions | 8.6.20, 9.5.2 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2026-30966?

Upgrade parse-server to a fixed version for your release line: 8.6.20 or 9.5.2-alpha.7.

## Is CVE-2026-30966 being exploited?

There is no known exploitation of CVE-2026-30966 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)
- [CVE-2022-39396](https://insights.sbomify.com/CVE-2022-39396/): Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30966 and fix it if it is affected.

What it is: CVE-2026-30966 is a critical vulnerability in Parseplatform Parse-Server, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-30966 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 8.6.20
- parse-server (npm): affected all versions; fixed in 8.6.20
- parse-server (npm): affected from 9.0.0-alpha.1; fixed in 9.5.2-alpha.7
- parse-server (npm): affected from 9.0.0-alpha.1; fixed in 9.5.2-alpha.7
- parse (Bitnami): affected all versions; fixed in 8.6.20, 9.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30966/ (Markdown: https://insights.sbomify.com/CVE-2026-30966/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30966
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30966
- OSV: https://osv.dev/vulnerability/CVE-2026-30966

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30966/
Summaries are generated and may contain mistakes; the official description above is the record.
