# CVE-2026-30971: ZoneMinder: Authenticated RCE via command injection in monitor Device Path

> Authenticated attackers can execute arbitrary commands as the web server user by injecting shell metacharacters into the monitor Device Path field.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-30971, GHSA-g66m-77fq-79v9, UBUNTU-CVE-2026-30971

## What is CVE-2026-30971?

CVE-2026-30971 is a high-severity command injection vulnerability in zoneminder, published on 16 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ZoneMinder is a free, open source closed-circuit television software application. Prior to 1.39.2, 1.38.2, and 1.36.40, ZoneMinder interpolates an unvalidated monitor Device field into shell commands in PHP and Perl control paths when an authenticated user with monitor-create or monitor-edit permission saves a Local monitor whose Device Path contains shell metacharacters and the monitor control or startup path runs. In this attack mechanism, the stored Device value reaches Perl qx() and backtick execution before zmdc.pl argument detainting, while separate PHP command paths use bypassable escapeshellcmd defenses. The attacker can execute arbitrary commands as the web server user. This vulnerability is fixed in 1.39.2, 1.38.2, and 1.36.40.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-30971?


## How do I fix CVE-2026-30971?

No fix has been published for CVE-2026-30971 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-30971 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30971 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30971 and fix it if it is affected.

What it is: CVE-2026-30971 is a high-severity command injection vulnerability in zoneminder, published on 16 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30971 exists.

Affected product: zoneminder. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30971/ (Markdown: https://insights.sbomify.com/CVE-2026-30971/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30971
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30971
- OSV: https://osv.dev/vulnerability/CVE-2026-30971

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30971/
Summaries are generated and may contain mistakes; the official description above is the record.
