# CVE-2026-30973: Zip Slip arbitrary file write in @appium/support ZIP extraction

> Attackers can write arbitrary files outside the destination directory via malicious ZIP entries due to a broken path traversal check in the Appium support library.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 12 Mar 2026
- **Also known as:** GHSA-rfx7-4xw3-gh4m

## What is CVE-2026-30973?

CVE-2026-30973 is a medium-severity path traversal vulnerability in @appium support, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Appium is an automation framework that provides WebDriver-based automation possibilities for a wide range platforms. Prior to 7.0.6, @appium/support contains a ZIP extraction implementation (extractAllTo() via ZipExtractor.extract()) with a path traversal (Zip Slip) check that is non-functional. The check at line 88 of packages/support/lib/zip.js creates an Error object but never throws it, allowing malicious ZIP entries with ../ path components to write files outside the intended destination directory. This affects all JS-based extractions (the default code path), not only those using the fileNamesEncoding option. This vulnerability is fixed in 7.0.6.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-30973?

2 open source packages ship an affected version, including @appium/support. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@appium/support` | npm | All versions | 7.0.6 |
| `@appium/support` | npm | All versions | 7.0.6 |

Products: Appium Appium\/Support.

## How do I fix CVE-2026-30973?

Upgrade @appium/support to 7.0.6 or later.

## Is CVE-2026-30973 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30973 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30973 and fix it if it is affected.

What it is: CVE-2026-30973 is a medium-severity path traversal vulnerability in @appium support, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30973 exists.

Affected packages and fixed versions:
- @appium/support (npm): affected all versions; fixed in 7.0.6
- @appium/support (npm): affected all versions; fixed in 7.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30973/ (Markdown: https://insights.sbomify.com/CVE-2026-30973/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30973
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30973
- OSV: https://osv.dev/vulnerability/CVE-2026-30973

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30973/
Summaries are generated and may contain mistakes; the official description above is the record.
