CVE-2026-3105 SQL Injection in Contact Activity API Sorting
Authenticated users can inject arbitrary SQL commands via the contact activity sorting parameter, potentially accessing or modifying data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-3105?
CVE-2026-3105 is a high-severity SQL injection vulnerability in Mautic, published on 24 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
SummaryThis advisory addresses a SQL injection vulnerability in the API endpoint used for retrieving contact activities. A vulnerability exists in the query construction for the Contact Activity timeline where the parameter responsible for determining the sort direction was not strictly validated against an allowlist, potentially allowing authenticated users to inject arbitrary SQL commands via the API.
MitigationPlease update to 4.4.19, 5.2.10, 6.0.8, 7.0.1 or later.
WorkaroundsNone.
ReferencesIf you have any questions or comments about this advisory:
Email us at [email protected]
Weakness: CWE-89
Which versions are affected by CVE-2026-3105?
6 open source packages ship an affected version, including mautic/core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mautic/core Packagist | From 2.10.0 | 5.2.10 |
mautic/core Packagist | From 2.10.0 | 5.2.10 |
mautic/core Packagist | From 6.0.0-alpha | 6.0.8 |
mautic/core Packagist | From 6.0.0-alpha | 6.0.8 |
mautic/core Packagist | From 7.0.0-alpha | 7.0.1 |
mautic/core Packagist | From 7.0.0-alpha | 7.0.1 |
Products include Acquia Mautic.
How do I fix CVE-2026-3105?
Upgrade mautic/core to a fixed version for your release line: 5.2.10, 6.0.8 or 7.0.1.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2026-3105 being exploited?
There is no known exploitation of CVE-2026-3105 in the wild and no public exploit code.
Other vulnerabilities in Mautic
- CVE-2022-25772 Cross-site Scripting vulnerability in Mautic's tracking pixel functionality
- CVE-2020-35125 Mautic is vulnerable to XSS vulnerability
- CVE-2020-35124 XSS vulnerability leveraged through referrers could allow un-authorized admin access in Mautic
- CVE-2024-47051 Remote Code Execution & File Deletion in Asset Uploads
- CVE-2020-35128 Mautic stored Cross-site Scripting (XSS)
Sources
Also known as GHSA-r5j5-q42h-fc93.