CVE-2026-3108 Terminal Escape Injection in mmctl Report Posts Command

High 8.0 Published Updated

Attackers can manipulate administrator terminals via crafted messages in mmctl, enabling screen manipulation and clipboard hijacking.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-3108?

CVE-2026-3108 is a high-severity vulnerability in Mattermost Mattermost Server, published on 26 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Mattermost versions 11.2.x <= 11.2.2, 10.11.x <= 10.11.10, 11.4.x <= 11.4.0, 11.3.x <= 11.3.1 fail to sanitize user-controlled post content in the mmctl commands terminal output which allows attackers to manipulate administrator terminals via crafted messages containing ANSI and OSC escape sequences that enable screen manipulation, fake prompts, and clipboard hijacking.. Mattermost Advisory ID: MMSA-2026-00599

Weakness: CWE-150

Which versions are affected by CVE-2026-3108?

14 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoFrom 10.11.0-rc110.11.11
github.com/mattermost/mattermost/server/v8 GoFrom 10.11.0-rc110.11.11
github.com/mattermost/mattermost/server/v8 GoFrom 11.2.0-rc111.2.3
github.com/mattermost/mattermost/server/v8 GoFrom 11.2.0-rc111.2.3
github.com/mattermost/mattermost/server/v8 GoFrom 11.3.0-rc111.3.2
github.com/mattermost/mattermost/server/v8 GoFrom 11.3.0-rc111.3.2
8 more packages
github.com/mattermost/mattermost/server/v8 GoFrom 11.4.0-rc111.4.1
github.com/mattermost/mattermost/server/v8 GoFrom 11.4.0-rc111.4.1
github.com/mattermost/mattermost/server/v8 GoFrom 8.0.0-20260105080200-d27a2195068d8.0.0-20260217110922-b7d4a1f1f59b
github.com/mattermost/mattermost/server/v8 GoFrom 8.0.0-20260105080200-d27a2195068d8.0.0-20260217110922-b7d4a1f1f59b
github.com/mattermost/mattermost/server/v8 GoFrom 8.0.0-20260105080200-d27a2195068d8.0.0-20260217110922-b7d4a1f1f59b
github.com/mattermost/mattermost-server GoFrom 10.11.0-rc1+incompatible10.11.11+incompatible, 11.2.3+incompatible, 11.3.2+incompatible, 11.4.1+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone

Products include Mattermost Mattermost Server.

How do I fix CVE-2026-3108?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 10.11.11, 11.2.3, 11.3.2 or 11.4.1.

Is CVE-2026-3108 being exploited?

There is no known exploitation of CVE-2026-3108 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-3439-vqgj-2gcf, GO-2026-5067.

Is CVE-2026-3108 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free