# CVE-2026-3114: Zip Bomb Denial of Service via Unrestricted Archive Decompression

> Authenticated users can cause server memory exhaustion and denial of service by uploading crafted zip bomb archives to Mattermost.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2026
- **Updated:** 26 Mar 2026
- **Also known as:** GHSA-vhgh-g7x8-4rx8, GO-2026-5663

## What is CVE-2026-3114?

CVE-2026-3114 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 26 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 11.4.x <= 11.4.0, 11.3.x <= 11.3.1, 11.2.x <= 11.2.3, 10.11.x <= 10.11.11 fail to validate decompressed archive entry sizes during file extraction which allows authenticated users with file upload permissions to cause a denial of service via crafted zip archives containing highly compressed entries (zip bombs) that exhaust server memory.. Mattermost Advisory ID: MMSA-2026-00598

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-3114?

14 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.11.0 | 10.11.12 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.11.0 | 10.11.12 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 11.2.0 | 11.2.4 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 11.2.0 | 11.2.4 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 11.3.0 | 11.3.2 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 11.3.0 | 11.3.2 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 11.4.0 | 11.4.1 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 11.4.0 | 11.4.1 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 8.0.0-20260105080200-d27a2195068d | 8.0.0-20260217110922-b7d4a1f1f59b |
| `github.com/mattermost/mattermost/server/v8` | Go | From 8.0.0-20260105080200-d27a2195068d | 8.0.0-20260217110922-b7d4a1f1f59b |
| `github.com/mattermost/mattermost/server/v8` | Go | From 8.0.0-20260105080200-d27a2195068d | 8.0.0-20260217110922-b7d4a1f1f59b |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0+incompatible | 10.11.12+incompatible, 11.2.4+incompatible, 11.3.2+incompatible, 11.4.1+incompatible |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2026-3114?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 10.11.12, 11.2.4, 11.3.2 or 11.4.1.

## Is CVE-2026-3114 being exploited?

There is no known exploitation of CVE-2026-3114 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-3114 and fix it if it is affected.

What it is: CVE-2026-3114 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 26 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-3114 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.11.0; fixed in 10.11.12
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.11.0; fixed in 10.11.12
- github.com/mattermost/mattermost/server/v8 (Go): affected from 11.2.0; fixed in 11.2.4
- github.com/mattermost/mattermost/server/v8 (Go): affected from 11.2.0; fixed in 11.2.4
- github.com/mattermost/mattermost/server/v8 (Go): affected from 11.3.0; fixed in 11.3.2
- github.com/mattermost/mattermost/server/v8 (Go): affected from 11.3.0; fixed in 11.3.2
- github.com/mattermost/mattermost/server/v8 (Go): affected from 11.4.0; fixed in 11.4.1
- github.com/mattermost/mattermost/server/v8 (Go): affected from 11.4.0; fixed in 11.4.1
- github.com/mattermost/mattermost/server/v8 (Go): affected from 8.0.0-20260105080200-d27a2195068d; fixed in 8.0.0-20260217110922-b7d4a1f1f59b
- github.com/mattermost/mattermost/server/v8 (Go): affected from 8.0.0-20260105080200-d27a2195068d; fixed in 8.0.0-20260217110922-b7d4a1f1f59b
- github.com/mattermost/mattermost/server/v8 (Go): affected from 8.0.0-20260105080200-d27a2195068d; fixed in 8.0.0-20260217110922-b7d4a1f1f59b
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0+incompatible; fixed in 10.11.12+incompatible, 11.2.4+incompatible, 11.3.2+incompatible, 11.4.1+incompatible

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-3114/ (Markdown: https://insights.sbomify.com/CVE-2026-3114/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-3114
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-3114
- OSV: https://osv.dev/vulnerability/CVE-2026-3114

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-3114/
Summaries are generated and may contain mistakes; the official description above is the record.
