# CVE-2026-31377: Apache Doris: Improper Authentication Allows Unauthorized Access to FE Meta Service

> Unauthenticated attackers can bypass authentication to access internal metadata endpoints, exposing sensitive cluster information in Apache Doris.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 23 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** GHSA-6cx7-4x8x-cqpx

## What is CVE-2026-31377?

CVE-2026-31377 is a high-severity authentication bypass vulnerability in Apache Doris, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An Improper Authentication vulnerability in the Apache Doris Frontend (FE) meta service allows an unauthenticated remote attacker to access internal metadata service endpoints.

The affected endpoints relied on client-supplied node information for authentication without providing sufficient authentication of the requesting party. Under certain network configurations, a remote attacker may be able to bypass the intended access control and access internal FE metadata interfaces, potentially exposing sensitive cluster information.

This issue affects Apache Doris: from 2.0.0 through 2.0.*, from 2.1.0 through 2.1.*, from 3.0.0 through 3.0.*, from 3.1.0 through 3.1.*, from 4.0.0 before 4.0.8, and from 4.1.0 before 4.1.4. Versions 1.2.x and earlier are not affected by this header-trust vulnerability.

Users are recommended to upgrade to a fixed release (4.0.8 or 4.1.4), which fixes the issue.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-31377?


## How do I fix CVE-2026-31377?

No fix has been published for CVE-2026-31377 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-31377 being exploited?

There is no known exploitation of CVE-2026-31377 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31377 and fix it if it is affected.

What it is: CVE-2026-31377 is a high-severity authentication bypass vulnerability in Apache Doris, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-31377 in the wild and no public exploit code.

Affected product: Apache Doris. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31377/ (Markdown: https://insights.sbomify.com/CVE-2026-31377/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31377
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31377
- OSV: https://osv.dev/vulnerability/CVE-2026-31377

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31377/
Summaries are generated and may contain mistakes; the official description above is the record.
