CVE-2026-31380 Apache OFBiz: FreeMarker SSTI via Duplicate Parameter Sanitization Bypass
Attackers can execute arbitrary code via FreeMarker SSTI in Apache OFBiz by bypassing parameter sanitization, requiring an upgrade to the latest version.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-31380?
CVE-2026-31380 is a medium-severity code injection vulnerability in Apache Ofbiz, published on 19 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Neutralization of Special Elements used in an Expression Language Statement ('Expression Language Injection') vulnerability in Apache OFBiz.
This issue affects Apache OFBiz: before 24.09.06.
Users are recommended to upgrade to version 24.09.06, which fixes the issue.
Weakness: CWE-917
Which versions are affected by CVE-2026-31380?
It affects 1 product.
Products include Apache Ofbiz.
How do I fix CVE-2026-31380?
No fix has been published for CVE-2026-31380 yet. Limit exposure of the affected software until one is available.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-31380 being exploited?
There is no known exploitation of CVE-2026-31380 in the wild and no public exploit code.
Other vulnerabilities in Apache Ofbiz
- CVE-2024-45195 Apache OFBiz Forced Browsing
- CVE-2024-32113 Apache OFBiz Path Traversal
- CVE-2024-38856 Apache OFBiz Incorrect Authorization
- CVE-2013-2250 Code injection in n/a
- CVE-2012-3506 Unspecified vulnerability in the Apache Open For Business Project (aka OFBiz) 10.04.x before 10.04.03 has unknown impact and attack vectors.
Sources
Also known as GHSA-rxgg-wf6c-ff5j.