# CVE-2026-31387: Apache OFBiz: Cookie Manipulation Allows Authenticated JWT Forgery and Account Impersonation

> Attackers can forge JWTs via cookie manipulation to impersonate users and escalate privileges in Apache OFBiz.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 May 2026
- **Updated:** 19 May 2026
- **Also known as:** GHSA-3wxm-wq6x-mq3g

## What is CVE-2026-31387?

CVE-2026-31387 is a medium-severity authentication bypass vulnerability in Apache Ofbiz, published on 19 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Authentication vulnerability in Apache OFBiz.

This issue affects Apache OFBiz: before 24.09.06.

Users are recommended to upgrade to version 24.09.06, which fixes the issue.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-31387?

It affects 1 product.


Products: Apache Ofbiz.

## How do I fix CVE-2026-31387?

No fix has been published for CVE-2026-31387 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-31387 being exploited?

There is no known exploitation of CVE-2026-31387 in the wild and no public exploit code.

## Other vulnerabilities in Apache Ofbiz

- [CVE-2024-45195](https://insights.sbomify.com/CVE-2024-45195/): Apache OFBiz Forced Browsing (critical 9.8, exploited in the wild)
- [CVE-2024-32113](https://insights.sbomify.com/CVE-2024-32113/): Apache OFBiz Path Traversal (critical 9.1, exploited in the wild)
- [CVE-2024-38856](https://insights.sbomify.com/CVE-2024-38856/): Apache OFBiz Incorrect Authorization (high 8.1, exploited in the wild)
- [CVE-2013-2250](https://insights.sbomify.com/CVE-2013-2250/): Code injection in n/a (critical 10.0)
- [CVE-2012-3506](https://insights.sbomify.com/CVE-2012-3506/): Unspecified vulnerability in the Apache Open For Business Project (aka OFBiz) 10.04.x before 10.04.03 has unknown impact and attack vectors. (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31387 and fix it if it is affected.

What it is: CVE-2026-31387 is a medium-severity authentication bypass vulnerability in Apache Ofbiz, published on 19 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-31387 in the wild and no public exploit code.

Affected product: Apache Ofbiz. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31387/ (Markdown: https://insights.sbomify.com/CVE-2026-31387/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31387
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31387
- OSV: https://osv.dev/vulnerability/CVE-2026-31387

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31387/
Summaries are generated and may contain mistakes; the official description above is the record.
