CVE-2026-3160 Unintended Proxy or Intermediary ('Confused Deputy') in GitLab

Medium 5.8 Published Updated

Authenticated users can view Jira issues outside their project scope due to insufficient access control enforcement in the integration filter.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-3160?

CVE-2026-3160 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 13.7 before 18.9.7, 18.10 before 18.10.6, and 18.11 before 18.11.3 that could have allowed an authenticated user to view Jira issues outside the configured project scope due to an integration filter functioning only as a display control rather than enforcing access boundaries as specified.

Weakness: CWE-441

Which versions are affected by CVE-2026-3160?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.7.018.9.7, 18.10.6, 18.11.3

Products include Gitlab Gitlab.

How do I fix CVE-2026-3160?

Upgrade gitlab to a fixed version for your release line: 18.9.7, 18.10.6 or 18.11.3.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-3160 being exploited?

There is no known exploitation of CVE-2026-3160 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-3160, GHSA-255c-fxwg-6753, UBUNTU-CVE-2026-3160.

Is CVE-2026-3160 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free