{"answers":{"affected":"1 open source package ship an affected version, including discourse. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-31805 in the wild and no public exploit code.","fix":"Upgrade discourse to a fixed version for your release line: 2026.1.2, 2026.2.1 or 2026.3.0.","what":"CVE-2026-31805 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-31805 and fix it if it is affected.\n\nWhat it is: CVE-2026-31805 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-31805 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- discourse (Bitnami): affected from 2026.1.0; fixed in 2026.1.2, 2026.2.1, 2026.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-31805/ (Markdown: https://insights.sbomify.com/CVE-2026-31805/index.md)","id":"CVE-2026-31805","markdown":"https://insights.sbomify.com/CVE-2026-31805/index.md","name":"CVE-2026-31805","record":{"aliases":["BIT-discourse-2026-31805","GHSA-fgxm-prjv-g823"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Discourse forum","requires_auth":"none","summary":"Authenticated users can bypass poll authorization checks to vote on or modify polls they should not access by manipulating post_id parameters.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"discourse","vendor":"discourse"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, an authorization bypass in the poll plugin allowed authenticated users to vote on, remove votes from, or toggle the open/closed status of polls they did not have access to. By passing post_id as an array (e.g. post_id[]=\u0026post_id[]=), the authorization check resolves to the accessible post while the poll lookup resolves to a different post's poll. This affects the vote, remove_vote, and toggle_status endpoints in DiscoursePoll::PollsController. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Discourse has a poll authorization bypass via post_id array parameter","id":"CVE-2026-31805","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"discourse:discourse","products":["discourse:discourse"],"type":"missing_authorization","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"FreeRDP has a Heap Buffer Overflow in nsc_process_message() via Unchecked SURFACE_BITS_COMMAND Bitmap Dimensions","id":"CVE-2026-31806"},"packages":[{"ecosystem":"Bitnami","fixed":["2026.1.2","2026.2.1","2026.3.0"],"introduced":["2026.1.0","2026.2.0","2026.3.0"],"last_affected":[],"package":"discourse","purl":"pkg:bitnami/discourse","source":"BIT-discourse-2026-31805"}],"prev":{"headline":"Tautulli: Unauthenticated pms_image_proxy endpoint proxies arbitrary HTTP requests through the Plex Media Server","id":"CVE-2026-31804"},"products":["discourse"],"published":"2026-03-20","related":[{"cvss_score":10,"headline":"RCE via malicious SNS subscription payload","id":"CVE-2021-41163","kev_date_added":null,"published":"2021-10-20"},{"cvss_score":9.1,"headline":"Discourse vulnerable to RCE via admins uploading maliciously zipped file","id":"CVE-2022-36066","kev_date_added":null,"published":"2022-09-29"},{"cvss_score":8.9,"headline":"Discourse user account takeover via email and invite link","id":"CVE-2022-39356","kev_date_added":null,"published":"2022-11-02"},{"cvss_score":8.8,"headline":"Discourse vulnerable to Cross-site Scripting in local oneboxes","id":"CVE-2023-22468","kev_date_added":null,"published":"2023-01-26"},{"cvss_score":8.7,"headline":"Discourse leaks private topic title and post excerpt via user action API endpoint","id":"CVE-2026-27934","kev_date_added":null,"published":"2026-03-19"},{"cvss_score":8.7,"headline":"Discourse vulnerable to DoS via large URL payload in PM to a bot","id":"CVE-2025-48053","kev_date_added":null,"published":"2025-06-09"},{"cvss_score":8.6,"headline":"Discourse vulnerable to unlimited mentioned users in message serializer","id":"CVE-2023-48297","kev_date_added":null,"published":"2024-01-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-20","vendors":["discourse"]},"summary":"Authenticated users can bypass poll authorization checks to vote on or modify polls they should not access by manipulating post_id parameters.","url":"https://insights.sbomify.com/CVE-2026-31805/"}