CVE-2026-31812 Quinn affected by unauthenticated remote DoS via panic in QUIC transport parameter parsing
Remote attackers can cause a denial of service in applications using the Quinn QUIC library by sending a crafted packet that triggers a panic.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-31812?
CVE-2026-31812 is a high-severity denial of service vulnerability in quinn-rs quinn, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Quinn is a pure-Rust, async-compatible implementation of the IETF QUIC transport protocol. Prior to 0.11.14, a remote, unauthenticated attacker can trigger a denial of service in applications using vulnerable quinn versions by sending a crafted QUIC Initial packet containing malformed quic_transport_parameters. In quinn-proto parsing logic, attacker-controlled varints are decoded with unwrap(), so truncated encodings cause Err(UnexpectedEnd) and panic. This is reachable over the network with a single packet and no prior trust or authentication. This vulnerability is fixed in 0.11.14.
Weakness: CWE-248
Which versions are affected by CVE-2026-31812?
3 open source packages ship an affected version, including quinn-proto.
| Package | Affected | Fixed in |
|---|---|---|
quinn-proto crates.io | All versions | 0.11.14 |
quinn-proto crates.io | All versions | 0.11.14 |
quinn-proto crates.io | From 0.5.0 | 0.11.14 |
Linux distribution packages (33)
rust SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 1.94.0-150400.24.71.1 |
rust1.94 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 1.94.0-150300.7.6.1 |
rust SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 1.94.0-150400.24.71.1 |
rust1.94 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 1.94.0-150300.7.6.1 |
rust SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 1.94.0-150500.27.65.1 |
rust1.94 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 1.94.0-150300.7.6.1 |
rust SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 1.94.0-150500.27.65.1 |
rust1.94 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 1.94.0-150300.7.6.1 |
rust SUSE:Linux Enterprise Module for Development Tools 15 SP7 | All versions | 1.94.0-150500.27.65.1 |
rust1.92 SUSE:Linux Enterprise Module for Development Tools 15 SP7 | All versions | 1.92.0-150300.7.6.1 |
rust1.93 SUSE:Linux Enterprise Module for Development Tools 15 SP7 | All versions | 1.93.0-150300.7.6.1 |
rust1.94 SUSE:Linux Enterprise Module for Development Tools 15 SP7 | All versions | 1.94.0-150300.7.6.1 |
rust SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 1.94.0-150400.24.71.1 |
rust1.94 SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 1.94.0-150300.7.6.1 |
rust SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 1.94.0-150500.27.65.1 |
rust1.94 SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 1.94.0-150300.7.6.1 |
rust SUSE:Linux Enterprise Server 15 SP6-LTSS | All versions | 1.94.0-150500.27.65.1 |
rust1.94 SUSE:Linux Enterprise Server 15 SP6-LTSS | All versions | 1.94.0-150300.7.6.1 |
rust SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 1.94.0-150400.24.71.1 |
rust1.94 SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 1.94.0-150300.7.6.1 |
rust SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 1.94.0-150500.27.65.1 |
rust1.94 SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 1.94.0-150300.7.6.1 |
rust SUSE:Linux Enterprise Server for SAP Applications 15 SP6 | All versions | 1.94.0-150500.27.65.1 |
rust1.94 SUSE:Linux Enterprise Server for SAP Applications 15 SP6 | All versions | 1.94.0-150300.7.6.1 |
rust openSUSE:Leap 15.6 | All versions | 1.94.0-150500.27.65.1 |
rust1.92 openSUSE:Leap 15.6 | All versions | 1.92.0-150300.7.6.1 |
rust1.93 openSUSE:Leap 15.6 | All versions | 1.93.0-150300.7.6.1 |
rust1.94 openSUSE:Leap 15.6 | All versions | 1.94.0-150300.7.6.1 |
rust1.94 openSUSE:Leap 16.0 | All versions | 1.94.1-160000.1.1 |
python-uv openSUSE:Tumbleweed | All versions | 0.10.11-1.1 |
rust1.92 openSUSE:Tumbleweed | All versions | 1.92.0-2.1 |
rust1.93 openSUSE:Tumbleweed | All versions | 1.93.0-3.1 |
rust1.94 openSUSE:Tumbleweed | All versions | 1.94.0-2.1 |
How do I fix CVE-2026-31812?
Upgrade quinn-proto to 0.11.14 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-31812 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-31812 exists.
Sources
Also known as DEBIAN-CVE-2026-31812, GHSA-6xvm-j4wr-6v98, MINI-7738-rch2-rpvr, MINI-pxcx-gx6w-vfrx, MINI-q752-vwgg-fh85, RUSTSEC-2026-0037 and 10 more.