# CVE-2026-31812: Quinn affected by unauthenticated remote DoS via panic in QUIC transport parameter parsing

> Remote attackers can cause a denial of service in applications using the Quinn QUIC library by sending a crafted packet that triggers a panic.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 25 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-31812, GHSA-6xvm-j4wr-6v98, MINI-7738-rch2-rpvr, MINI-pxcx-gx6w-vfrx, MINI-q752-vwgg-fh85, RUSTSEC-2026-0037, SUSE-RU-2026:1001-1, SUSE-SU-2026:1337-1, SUSE-SU-2026:1415-1, SUSE-SU-2026:21357-1, UBUNTU-CVE-2026-31812, openSUSE-SU-2026:10380-1, openSUSE-SU-2026:10382-1, openSUSE-SU-2026:10383-1, openSUSE-SU-2026:10384-1, openSUSE-SU-2026:20569-1

## What is CVE-2026-31812?

CVE-2026-31812 is a high-severity denial of service vulnerability in quinn-rs quinn, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Quinn is a pure-Rust, async-compatible implementation of the IETF QUIC transport protocol. Prior to 0.11.14, a remote, unauthenticated attacker can trigger a denial of service in applications using vulnerable quinn versions by sending a crafted QUIC Initial packet containing malformed quic_transport_parameters. In quinn-proto parsing logic, attacker-controlled varints are decoded with unwrap(), so truncated encodings cause Err(UnexpectedEnd) and panic. This is reachable over the network with a single packet and no prior trust or authentication. This vulnerability is fixed in 0.11.14.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-31812?

3 open source packages ship an affected version, including quinn-proto.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `quinn-proto` | crates.io | All versions | 0.11.14 |
| `quinn-proto` | crates.io | All versions | 0.11.14 |
| `quinn-proto` | crates.io | From 0.5.0 | 0.11.14 |
| `rust` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 1.94.0-150400.24.71.1 |
| `rust1.94` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 1.94.0-150300.7.6.1 |
| `rust` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 1.94.0-150400.24.71.1 |
| `rust1.94` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 1.94.0-150300.7.6.1 |
| `rust` | SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 1.94.0-150500.27.65.1 |
| `rust1.94` | SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 1.94.0-150300.7.6.1 |
| `rust` | SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 1.94.0-150500.27.65.1 |
| `rust1.94` | SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 1.94.0-150300.7.6.1 |
| `rust` | SUSE:Linux Enterprise Module for Development Tools 15 SP7 | All versions | 1.94.0-150500.27.65.1 |
| `rust1.92` | SUSE:Linux Enterprise Module for Development Tools 15 SP7 | All versions | 1.92.0-150300.7.6.1 |
| `rust1.93` | SUSE:Linux Enterprise Module for Development Tools 15 SP7 | All versions | 1.93.0-150300.7.6.1 |
| `rust1.94` | SUSE:Linux Enterprise Module for Development Tools 15 SP7 | All versions | 1.94.0-150300.7.6.1 |
| `rust` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 1.94.0-150400.24.71.1 |
| `rust1.94` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 1.94.0-150300.7.6.1 |
| `rust` | SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 1.94.0-150500.27.65.1 |
| `rust1.94` | SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 1.94.0-150300.7.6.1 |
| `rust` | SUSE:Linux Enterprise Server 15 SP6-LTSS | All versions | 1.94.0-150500.27.65.1 |
| `rust1.94` | SUSE:Linux Enterprise Server 15 SP6-LTSS | All versions | 1.94.0-150300.7.6.1 |
| `rust` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 1.94.0-150400.24.71.1 |
| `rust1.94` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 1.94.0-150300.7.6.1 |
| `rust` | SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 1.94.0-150500.27.65.1 |
| `rust1.94` | SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 1.94.0-150300.7.6.1 |
| `rust` | SUSE:Linux Enterprise Server for SAP Applications 15 SP6 | All versions | 1.94.0-150500.27.65.1 |
| `rust1.94` | SUSE:Linux Enterprise Server for SAP Applications 15 SP6 | All versions | 1.94.0-150300.7.6.1 |
| `rust` | openSUSE:Leap 15.6 | All versions | 1.94.0-150500.27.65.1 |
| `rust1.92` | openSUSE:Leap 15.6 | All versions | 1.92.0-150300.7.6.1 |
| `rust1.93` | openSUSE:Leap 15.6 | All versions | 1.93.0-150300.7.6.1 |
| `rust1.94` | openSUSE:Leap 15.6 | All versions | 1.94.0-150300.7.6.1 |
| `rust1.94` | openSUSE:Leap 16.0 | All versions | 1.94.1-160000.1.1 |
| `python-uv` | openSUSE:Tumbleweed | All versions | 0.10.11-1.1 |
| `rust1.92` | openSUSE:Tumbleweed | All versions | 1.92.0-2.1 |
| `rust1.93` | openSUSE:Tumbleweed | All versions | 1.93.0-3.1 |
| `rust1.94` | openSUSE:Tumbleweed | All versions | 1.94.0-2.1 |

## How do I fix CVE-2026-31812?

Upgrade quinn-proto to 0.11.14 or later.

## Is CVE-2026-31812 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-31812 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31812 and fix it if it is affected.

What it is: CVE-2026-31812 is a high-severity denial of service vulnerability in quinn-rs quinn, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-31812 exists.

Affected packages and fixed versions:
- quinn-proto (crates.io): affected all versions; fixed in 0.11.14
- quinn-proto (crates.io): affected all versions; fixed in 0.11.14
- quinn-proto (crates.io): affected from 0.5.0; fixed in 0.11.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31812/ (Markdown: https://insights.sbomify.com/CVE-2026-31812/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31812
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31812
- OSV: https://osv.dev/vulnerability/CVE-2026-31812

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31812/
Summaries are generated and may contain mistakes; the official description above is the record.
