{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-31813 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-31813 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-31813 is a medium-severity authentication bypass vulnerability in supabase auth, published on 11 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-31813 and fix it if it is affected.\n\nWhat it is: CVE-2026-31813 is a medium-severity authentication bypass vulnerability in supabase auth, published on 11 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-31813 in the wild and no public exploit code.\n\nAffected product: supabase auth. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-31813/ (Markdown: https://insights.sbomify.com/CVE-2026-31813/index.md)","id":"CVE-2026-31813","markdown":"https://insights.sbomify.com/CVE-2026-31813/index.md","name":"CVE-2026-31813","record":{"aliases":["GHSA-v36f-qvww-8w8m"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Supabase Auth","requires_auth":"none","summary":"Attackers can hijack user accounts by crafting ID tokens when Apple or Azure providers are enabled, allowing unauthorized session issuance.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"auth","vendor":"supabase"}],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-290","name":"Authentication Bypass by Spoofing"}],"description":"Supabase Auth is a JWT based API for managing users and issuing JWT tokens. Prior to 2.185.0, a vulnerability has been identified that allows an attacker to issue sessions for arbitrary users using specially crafted ID tokens when the Apple or Azure providers are enabled. The attacker issues a valid, asymmetrically signed ID token from their issuer for each victim email address, which then is sent to the Supabase Auth token endpoint using the ID token flow. If the ID token is OIDC compliant, the Auth server would validate it against the attacker-controlled issuer and link the existing OIDC identity (Apple or Azure) of the victim to an additional OIDC identity based on the ID token contents. The Auth server would then issue a valid user session (access and refresh tokens) at the AAL1 level to the attacker. This vulnerability is fixed in 2.185.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Supabase Auth has insecure Apple and Azure authentication with ID tokens","id":"CVE-2026-31813","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"Yamux remote Panic via malformed WindowUpdate credit","id":"CVE-2026-31814"},"packages":[],"prev":{"headline":"Quinn affected by unauthenticated remote DoS via panic in QUIC transport parameter parsing","id":"CVE-2026-31812"},"products":["auth"],"published":"2026-03-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-11","vendors":["supabase"]},"summary":"Attackers can hijack user accounts by crafting ID tokens when Apple or Azure providers are enabled, allowing unauthorized session issuance.","url":"https://insights.sbomify.com/CVE-2026-31813/"}