# CVE-2026-31813: Supabase Auth has insecure Apple and Azure authentication with ID tokens

> Attackers can hijack user accounts by crafting ID tokens when Apple or Azure providers are enabled, allowing unauthorized session issuance.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Mar 2026
- **Updated:** 11 Mar 2026
- **Also known as:** GHSA-v36f-qvww-8w8m

## What is CVE-2026-31813?

CVE-2026-31813 is a medium-severity authentication bypass vulnerability in supabase auth, published on 11 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Supabase Auth is a JWT based API for managing users and issuing JWT tokens. Prior to 2.185.0, a vulnerability has been identified that allows an attacker to issue sessions for arbitrary users using specially crafted ID tokens when the Apple or Azure providers are enabled. The attacker issues a valid, asymmetrically signed ID token from their issuer for each victim email address, which then is sent to the Supabase Auth token endpoint using the ID token flow. If the ID token is OIDC compliant, the Auth server would validate it against the attacker-controlled issuer and link the existing OIDC identity (Apple or Azure) of the victim to an additional OIDC identity based on the ID token contents. The Auth server would then issue a valid user session (access and refresh tokens) at the AAL1 level to the attacker. This vulnerability is fixed in 2.185.0.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2026-31813?

It affects 1 product.


Products: Supabase Auth.

## How do I fix CVE-2026-31813?

No fix has been published for CVE-2026-31813 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-31813 being exploited?

There is no known exploitation of CVE-2026-31813 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31813 and fix it if it is affected.

What it is: CVE-2026-31813 is a medium-severity authentication bypass vulnerability in supabase auth, published on 11 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-31813 in the wild and no public exploit code.

Affected product: supabase auth. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31813/ (Markdown: https://insights.sbomify.com/CVE-2026-31813/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31813
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31813
- OSV: https://osv.dev/vulnerability/CVE-2026-31813

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31813/
Summaries are generated and may contain mistakes; the official description above is the record.
