{"answers":{"affected":"2 open source packages ship an affected version, including yamux. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-31814 in the wild and no public exploit code.","fix":"Upgrade yamux to 0.13.9 or later.","what":"CVE-2026-31814 is a high-severity vulnerability in libp2p rust-yamux, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-31814 and fix it if it is affected.\n\nWhat it is: CVE-2026-31814 is a high-severity vulnerability in libp2p rust-yamux, published on 13 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-31814 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yamux (crates.io): affected from 0.13.0; fixed in 0.13.9\n- yamux (crates.io): affected from 0.13.0; fixed in 0.13.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-31814/ (Markdown: https://insights.sbomify.com/CVE-2026-31814/index.md)","id":"CVE-2026-31814","markdown":"https://insights.sbomify.com/CVE-2026-31814/index.md","name":"CVE-2026-31814","record":{"aliases":["DEBIAN-CVE-2026-31814","GHSA-4w32-2493-32g7","UBUNTU-CVE-2026-31814"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust stream multiplexer","requires_auth":"none","summary":"A remote attacker can cause a denial of service in the Yamux library by sending a malformed WindowUpdate message that triggers an arithmetic overflow and panic.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"yamux","vendor":"protocol"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"Yamux is a stream multiplexer over reliable, ordered connections such as TCP/IP. From 0.13.0 to before 0.13.9, a specially crafted WindowUpdate can cause arithmetic overflow in send-window accounting, which triggers a panic in the connection state machine. This is remotely reachable over a normal network connection and does not require authentication. This vulnerability is fixed in 0.13.9.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Yamux remote Panic via malformed WindowUpdate credit","id":"CVE-2026-31814","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"integer_overflow","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"django-unicorn affected by component state manipulation via unvalidated attribute access","id":"CVE-2026-31815"},"packages":[{"ecosystem":"crates.io","fixed":["0.13.9"],"introduced":["0.13.0"],"last_affected":[],"package":"yamux","purl":null,"source":"GHSA-4w32-2493-32g7"},{"ecosystem":"crates.io","fixed":["0.13.9"],"introduced":["0.13.0"],"last_affected":[],"package":"yamux","purl":"pkg:cargo/yamux","source":"GHSA-4w32-2493-32g7"}],"prev":{"headline":"Supabase Auth has insecure Apple and Azure authentication with ID tokens","id":"CVE-2026-31813"},"products":["rust-yamux"],"published":"2026-03-13","related":[{"cvss_score":8.7,"headline":"Yamux remote Panic via malformed Data frame with SYN set and len = 262145","id":"CVE-2026-32314","kev_date_added":null,"published":"2026-03-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-03-13","vendors":["libp2p"]},"summary":"A remote attacker can cause a denial of service in the Yamux library by sending a malformed WindowUpdate message that triggers an arithmetic overflow and panic.","url":"https://insights.sbomify.com/CVE-2026-31814/"}