# CVE-2026-31818: Budibase: Server-Side Request Forgery via REST Connector with Empty Default Blacklist

> Attackers can exploit SSRF in Budibase's REST connector when the default IP blacklist is empty, bypassing security controls to access internal resources.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2026
- **Updated:** 3 Apr 2026
- **Also known as:** GHSA-7r9j-r86q-7g45

## What is CVE-2026-31818?

CVE-2026-31818 is a critical server-side request forgery vulnerability in budibase, published on 3 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Budibase is an open-source low-code platform. Prior to version 3.33.4, a server-side request forgery (SSRF) vulnerability exists in Budibase's REST datasource connector. The platform's SSRF protection mechanism (IP blacklist) is rendered completely ineffective because the BLACKLIST_IPS environment variable is not set by default in any of the official deployment configurations. When this variable is empty, the blacklist function unconditionally returns false, allowing all requests through without restriction. This issue has been patched in version 3.33.4.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2026-31818?

2 open source packages ship an affected version, including @budibase/backend-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/backend-core` | npm | All versions | 3.33.4 |
| `@budibase/backend-core` | npm | All versions | 3.33.4 |

Products: Budibase Budibase.

## How do I fix CVE-2026-31818?

Upgrade @budibase/backend-core to 3.33.4 or later.

## Is CVE-2026-31818 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-31818 exists.

## Other vulnerabilities in budibase

- [CVE-2026-54350](https://insights.sbomify.com/CVE-2026-54350/): Budibase: Anonymous NoSQL operator injection via published-app query templates (critical 10.0)
- [CVE-2026-27702](https://insights.sbomify.com/CVE-2026-27702/): Budibase Vulnerable to Remote Code Execution via Unsafe eval() in View Filter Map Function (Budibase Cloud) (critical 9.9)
- [CVE-2026-54352](https://insights.sbomify.com/CVE-2026-54352/): Budibase: Arbitrary file read by workspace-builder via PWA-zip symlink upload (critical 9.6)
- [CVE-2026-30240](https://insights.sbomify.com/CVE-2026-30240/): Budibase PWA ZIP Upload Path Traversal Allows Reading Arbitrary Server Files Including All Environment Secrets (critical 9.6)
- [CVE-2026-41428](https://insights.sbomify.com/CVE-2026-41428/): Budibase: Authentication Bypass via Unanchored Regex in Public Endpoint Matcher — Unauthenticated Access to Protected Endpoints (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31818 and fix it if it is affected.

What it is: CVE-2026-31818 is a critical server-side request forgery vulnerability in budibase, published on 3 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-31818 exists.

Affected packages and fixed versions:
- @budibase/backend-core (npm): affected all versions; fixed in 3.33.4
- @budibase/backend-core (npm): affected all versions; fixed in 3.33.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31818/ (Markdown: https://insights.sbomify.com/CVE-2026-31818/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31818
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31818
- OSV: https://osv.dev/vulnerability/CVE-2026-31818

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31818/
Summaries are generated and may contain mistakes; the official description above is the record.
