# CVE-2026-31819: Sylius has an Open Redirect via Referer Header

> Attackers can redirect users to malicious sites via Referer header manipulation, enabling phishing and credential theft on Sylius eCommerce platforms.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 11 Mar 2026
- **Also known as:** GHSA-9ffx-f77r-756w

## What is CVE-2026-31819?

CVE-2026-31819 is a medium-severity vulnerability in Sylius, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Sylius is an Open Source eCommerce Framework on Symfony. CurrencySwitchController::switchAction(), ImpersonateUserController::impersonateAction() and StorageBasedLocaleSwitcher::handle() use the HTTP Referer header directly when redirecting. The attack requires the victim to click a legitimate application link placed on an attacker-controlled page. The browser automatically sends the attacker's site as the Referer, and the application redirects back to it. This can be used for phishing or credential theft, as the redirect originates from a trusted domain. The severity varies by endpoint; public endpoints require no authentication and are trivially exploitable, while admin-only endpoints require an authenticated session but remain vulnerable if an admin follows a link from an external source such as email or chat. The issue is fixed in versions: 1.9.12, 1.10.16, 1.11.17, 1.12.23, 1.13.15, 1.14.18, 2.0.16, 2.1.12, 2.2.3 and above.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-31819?

18 open source packages ship an affected version, including sylius/sylius. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sylius/sylius` | Packagist | All versions | 1.9.12 |
| `sylius/sylius` | Packagist | All versions | 1.9.12 |
| `sylius/sylius` | Packagist | From 1.10.0 | 1.10.16 |
| `sylius/sylius` | Packagist | From 1.10.0 | 1.10.16 |
| `sylius/sylius` | Packagist | From 1.11.0 | 1.11.17 |
| `sylius/sylius` | Packagist | From 1.11.0 | 1.11.17 |
| `sylius/sylius` | Packagist | From 1.12.0 | 1.12.23 |
| `sylius/sylius` | Packagist | From 1.12.0 | 1.12.23 |
| `sylius/sylius` | Packagist | From 1.13.0 | 1.13.15 |
| `sylius/sylius` | Packagist | From 1.13.0 | 1.13.15 |
| `sylius/sylius` | Packagist | From 1.14.0 | 1.14.18 |
| `sylius/sylius` | Packagist | From 1.14.0 | 1.14.18 |
| `sylius/sylius` | Packagist | From 2.0.0 | 2.0.16 |
| `sylius/sylius` | Packagist | From 2.0.0 | 2.0.16 |
| `sylius/sylius` | Packagist | From 2.1.0 | 2.1.12 |
| `sylius/sylius` | Packagist | From 2.1.0 | 2.1.12 |
| `sylius/sylius` | Packagist | From 2.2.0 | 2.2.3 |
| `sylius/sylius` | Packagist | From 2.2.0 | 2.2.3 |

Products: Sylius Sylius.

## How do I fix CVE-2026-31819?

Upgrade sylius/sylius to a fixed version for your release line: 1.9.12, 1.10.16, 1.11.17 or 1.12.23.

## Is CVE-2026-31819 being exploited?

There is no known exploitation of CVE-2026-31819 in the wild and no public exploit code.

## Other vulnerabilities in Sylius

- [CVE-2026-31824](https://insights.sbomify.com/CVE-2026-31824/): Sylius has a Promotion Usage Limit Bypass via Race Condition (high 8.2)
- [CVE-2024-57610](https://insights.sbomify.com/CVE-2024-57610/): Denial of service in n/a (high 7.5)
- [CVE-2026-31820](https://insights.sbomify.com/CVE-2026-31820/): Sylius affected by IDOR in Cart and Checkout LiveComponents (high 7.1)
- [CVE-2022-24743](https://insights.sbomify.com/CVE-2022-24743/): Insufficient Session Expiration in Sylius (high 7.1)
- [CVE-2026-31821](https://insights.sbomify.com/CVE-2026-31821/): Sylius is Missing Authorization in API v2 Add Item Endpoint (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31819 and fix it if it is affected.

What it is: CVE-2026-31819 is a medium-severity vulnerability in Sylius, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-31819 in the wild and no public exploit code.

Affected packages and fixed versions:
- sylius/sylius (Packagist): affected all versions; fixed in 1.9.12
- sylius/sylius (Packagist): affected all versions; fixed in 1.9.12
- sylius/sylius (Packagist): affected from 1.10.0; fixed in 1.10.16
- sylius/sylius (Packagist): affected from 1.10.0; fixed in 1.10.16
- sylius/sylius (Packagist): affected from 1.11.0; fixed in 1.11.17
- sylius/sylius (Packagist): affected from 1.11.0; fixed in 1.11.17
- sylius/sylius (Packagist): affected from 1.12.0; fixed in 1.12.23
- sylius/sylius (Packagist): affected from 1.12.0; fixed in 1.12.23
- sylius/sylius (Packagist): affected from 1.13.0; fixed in 1.13.15
- sylius/sylius (Packagist): affected from 1.13.0; fixed in 1.13.15
- sylius/sylius (Packagist): affected from 1.14.0; fixed in 1.14.18
- sylius/sylius (Packagist): affected from 1.14.0; fixed in 1.14.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31819/ (Markdown: https://insights.sbomify.com/CVE-2026-31819/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31819
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31819
- OSV: https://osv.dev/vulnerability/CVE-2026-31819

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31819/
Summaries are generated and may contain mistakes; the official description above is the record.
