# CVE-2026-31821: Sylius is Missing Authorization in API v2 Add Item Endpoint

> Unauthenticated attackers can add items to other customers' carts by exploiting missing ownership verification in the Sylius API v2 add item endpoint.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 11 Mar 2026
- **Also known as:** GHSA-wjmg-4cq5-m8hg

## What is CVE-2026-31821?

CVE-2026-31821 is a medium-severity missing authorization vulnerability in Sylius, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Sylius is an Open Source eCommerce Framework on Symfony. The POST /api/v2/shop/orders/{tokenValue}/items endpoint does not verify cart ownership. An unauthenticated attacker can add items to other registered customers' carts by knowing the cart tokenValue. An attacker who obtains a cart tokenValue can add arbitrary items to another customer's cart. The endpoint returns the full cart representation in the response (HTTP 201). The issue is fixed in versions: 2.0.16, 2.1.12, 2.2.3 and above.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-31821?

6 open source packages ship an affected version, including sylius/sylius. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sylius/sylius` | Packagist | From 2.0.0 | 2.0.16 |
| `sylius/sylius` | Packagist | From 2.0.0 | 2.0.16 |
| `sylius/sylius` | Packagist | From 2.1.0 | 2.1.12 |
| `sylius/sylius` | Packagist | From 2.1.0 | 2.1.12 |
| `sylius/sylius` | Packagist | From 2.2.0 | 2.2.3 |
| `sylius/sylius` | Packagist | From 2.2.0 | 2.2.3 |

Products: Sylius Sylius.

## How do I fix CVE-2026-31821?

Upgrade sylius/sylius to a fixed version for your release line: 2.0.16, 2.1.12 or 2.2.3.

## Is CVE-2026-31821 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-31821 exists.

## Other vulnerabilities in Sylius

- [CVE-2026-31824](https://insights.sbomify.com/CVE-2026-31824/): Sylius has a Promotion Usage Limit Bypass via Race Condition (high 8.2)
- [CVE-2024-57610](https://insights.sbomify.com/CVE-2024-57610/): Denial of service in n/a (high 7.5)
- [CVE-2026-31820](https://insights.sbomify.com/CVE-2026-31820/): Sylius affected by IDOR in Cart and Checkout LiveComponents (high 7.1)
- [CVE-2022-24743](https://insights.sbomify.com/CVE-2022-24743/): Insufficient Session Expiration in Sylius (high 7.1)
- [CVE-2026-31819](https://insights.sbomify.com/CVE-2026-31819/): Sylius has an Open Redirect via Referer Header (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31821 and fix it if it is affected.

What it is: CVE-2026-31821 is a medium-severity missing authorization vulnerability in Sylius, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-31821 exists.

Affected packages and fixed versions:
- sylius/sylius (Packagist): affected from 2.0.0; fixed in 2.0.16
- sylius/sylius (Packagist): affected from 2.0.0; fixed in 2.0.16
- sylius/sylius (Packagist): affected from 2.1.0; fixed in 2.1.12
- sylius/sylius (Packagist): affected from 2.1.0; fixed in 2.1.12
- sylius/sylius (Packagist): affected from 2.2.0; fixed in 2.2.3
- sylius/sylius (Packagist): affected from 2.2.0; fixed in 2.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31821/ (Markdown: https://insights.sbomify.com/CVE-2026-31821/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31821
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31821
- OSV: https://osv.dev/vulnerability/CVE-2026-31821

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31821/
Summaries are generated and may contain mistakes; the official description above is the record.
