CVE-2026-31823 Sylius has Authenticated Stored XSS

Medium 4.8 Published Updated

Authenticated attackers can inject persistent JavaScript via unsanitized entity names in Sylius, affecting both storefront and admin panels.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-31823?

CVE-2026-31823 is a medium-severity cross-site scripting vulnerability in Sylius, published on 10 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Sylius is an Open Source eCommerce Framework on Symfony. An authenticated stored cross-site scripting (XSS) vulnerability exists in multiple places across the shop frontend and admin panel due to unsanitized entity names being rendered as raw HTML. Shop breadcrumbs (shared/breadcrumbs.html.twig): The breadcrumbs macro uses the Twig |raw filter on label values. Since taxon names, product names, and ancestor names flow directly into these labels, a malicious taxon name like <img src=x onerror=alert('XSS')> is rendered and executed as JavaScript on the storefront. Admin product taxon picker (ProductTaxonTreeController.js): The rowRenderer method interpolates ${name} directly into a template literal building HTML, allowing script injection through taxon names in the admin panel. Admin autocomplete fields (Tom Select): Dropdown items and options render entity names as raw HTML without escaping, allowing XSS through any autocomplete field displaying entity names. An authenticated administrator can inject arbitrary HTML or JavaScript via entity names (e.g. taxon name) that is persistently rendered for all users. The issue is fixed in versions: 1.9.12, 1.10.16, 1.11.17, 1.12.23, 1.13.15, 1.14.18, 2.0.16, 2.1.12, 2.2.3 and above.

Weakness: CWE-79

Which versions are affected by CVE-2026-31823?

6 open source packages ship an affected version, including sylius/sylius. It affects 1 product.

PackageAffectedFixed in
sylius/sylius PackagistFrom 2.0.02.0.16
sylius/sylius PackagistFrom 2.0.02.0.16
sylius/sylius PackagistFrom 2.1.02.1.12
sylius/sylius PackagistFrom 2.1.02.1.12
sylius/sylius PackagistFrom 2.2.02.2.3
sylius/sylius PackagistFrom 2.2.02.2.3

Products include Sylius Sylius.

How do I fix CVE-2026-31823?

Upgrade sylius/sylius to a fixed version for your release line: 2.0.16, 2.1.12 or 2.2.3.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-31823 being exploited?

There is no known exploitation of CVE-2026-31823 in the wild and no public exploit code.

Sources

Also known as GHSA-mx4q-xxc9-pf5q.

Is CVE-2026-31823 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free