# CVE-2026-31823: Sylius has Authenticated Stored XSS

> Authenticated attackers can inject persistent JavaScript via unsanitized entity names in Sylius, affecting both storefront and admin panels.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 11 Mar 2026
- **Also known as:** GHSA-mx4q-xxc9-pf5q

## What is CVE-2026-31823?

CVE-2026-31823 is a medium-severity cross-site scripting vulnerability in Sylius, published on 10 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Sylius is an Open Source eCommerce Framework on Symfony. An authenticated stored cross-site scripting (XSS) vulnerability exists in multiple places across the shop frontend and admin panel due to unsanitized entity names being rendered as raw HTML. Shop breadcrumbs (shared/breadcrumbs.html.twig): The breadcrumbs macro uses the Twig |raw filter on label values. Since taxon names, product names, and ancestor names flow directly into these labels, a malicious taxon name like <img src=x onerror=alert('XSS')> is rendered and executed as JavaScript on the storefront. Admin product taxon picker (ProductTaxonTreeController.js): The rowRenderer method interpolates ${name} directly into a template literal building HTML, allowing script injection through taxon names in the admin panel. Admin autocomplete fields (Tom Select): Dropdown items and options render entity names as raw HTML without escaping, allowing XSS through any autocomplete field displaying entity names. An authenticated administrator can inject arbitrary HTML or JavaScript via entity names (e.g. taxon name) that is persistently rendered for all users. The issue is fixed in versions: 1.9.12, 1.10.16, 1.11.17, 1.12.23, 1.13.15, 1.14.18, 2.0.16, 2.1.12, 2.2.3 and above.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-31823?

6 open source packages ship an affected version, including sylius/sylius. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sylius/sylius` | Packagist | From 2.0.0 | 2.0.16 |
| `sylius/sylius` | Packagist | From 2.0.0 | 2.0.16 |
| `sylius/sylius` | Packagist | From 2.1.0 | 2.1.12 |
| `sylius/sylius` | Packagist | From 2.1.0 | 2.1.12 |
| `sylius/sylius` | Packagist | From 2.2.0 | 2.2.3 |
| `sylius/sylius` | Packagist | From 2.2.0 | 2.2.3 |

Products: Sylius Sylius.

## How do I fix CVE-2026-31823?

Upgrade sylius/sylius to a fixed version for your release line: 2.0.16, 2.1.12 or 2.2.3.

## Is CVE-2026-31823 being exploited?

There is no known exploitation of CVE-2026-31823 in the wild and no public exploit code.

## Other vulnerabilities in Sylius

- [CVE-2026-31824](https://insights.sbomify.com/CVE-2026-31824/): Sylius has a Promotion Usage Limit Bypass via Race Condition (high 8.2)
- [CVE-2024-57610](https://insights.sbomify.com/CVE-2024-57610/): Denial of service in n/a (high 7.5)
- [CVE-2026-31820](https://insights.sbomify.com/CVE-2026-31820/): Sylius affected by IDOR in Cart and Checkout LiveComponents (high 7.1)
- [CVE-2022-24743](https://insights.sbomify.com/CVE-2022-24743/): Insufficient Session Expiration in Sylius (high 7.1)
- [CVE-2026-31819](https://insights.sbomify.com/CVE-2026-31819/): Sylius has an Open Redirect via Referer Header (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31823 and fix it if it is affected.

What it is: CVE-2026-31823 is a medium-severity cross-site scripting vulnerability in Sylius, published on 10 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-31823 in the wild and no public exploit code.

Affected packages and fixed versions:
- sylius/sylius (Packagist): affected from 2.0.0; fixed in 2.0.16
- sylius/sylius (Packagist): affected from 2.0.0; fixed in 2.0.16
- sylius/sylius (Packagist): affected from 2.1.0; fixed in 2.1.12
- sylius/sylius (Packagist): affected from 2.1.0; fixed in 2.1.12
- sylius/sylius (Packagist): affected from 2.2.0; fixed in 2.2.3
- sylius/sylius (Packagist): affected from 2.2.0; fixed in 2.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31823/ (Markdown: https://insights.sbomify.com/CVE-2026-31823/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31823
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31823
- OSV: https://osv.dev/vulnerability/CVE-2026-31823

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31823/
Summaries are generated and may contain mistakes; the official description above is the record.
