CVE-2026-31824 Sylius has a Promotion Usage Limit Bypass via Race Condition

High 8.2 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-31824?

CVE-2026-31824 is a high-severity vulnerability in Sylius, published on 10 Mar 2026.

Official description

Sylius is an Open Source eCommerce Framework on Symfony. A Time-of-Check To Time-of-Use (TOCTOU) race condition was discovered in the promotion usage limit enforcement. The same class of vulnerability affects the promotion usage limit (the global used counter on Promotion entities), coupon usage limit (the global used counter on PromotionCoupon entities), and coupon per-customer usage limit (the per-customer redemption count on PromotionCoupon entities). In all three cases, the eligibility check reads the used counter (or order count) from an in-memory Doctrine entity during validation, while the actual usage increment in OrderPromotionsUsageModifier happens later during order completion — with no database-level locking or atomic operations between the two phases. Because Doctrine flushes an absolute value (SET used = 1) rather than an atomic increment (SET used = used + 1), and because the affected entities lack optimistic locking, concurrent requests all read the same stale usage counts and pass the eligibility checks simultaneously. An attacker can exploit this by preparing multiple carts with the same limited-use promotion or coupon and firing simultaneous PATCH /api/v2/shop/orders/{token}/complete requests. All requests pass the usage limit checks and complete successfully, allowing a single-use promotion or coupon to be redeemed an arbitrary number of times. The per-customer limit can be bypassed in the same way by a single customer completing multiple orders concurrently. No authentication is required to exploit this vulnerability. This may lead to direct financial loss through unlimited redemption of limited-use promotions and discount coupons. The issue is fixed in versions: 1.9.12, 1.10.16, 1.11.17, 1.12.23, 1.13.15, 1.14.18, 2.0.16, 2.1.12, 2.2.3 and above.

Weakness: CWE-367, CWE-362

Which versions are affected by CVE-2026-31824?

18 open source packages ship an affected version, including sylius/sylius. It affects 1 product.

PackageAffectedFixed in
sylius/sylius PackagistAll versions1.9.12
sylius/sylius PackagistAll versions1.9.12
sylius/sylius PackagistFrom 1.10.01.10.16
sylius/sylius PackagistFrom 1.10.01.10.16
sylius/sylius PackagistFrom 1.11.01.11.17
sylius/sylius PackagistFrom 1.11.01.11.17
12 more packages
sylius/sylius PackagistFrom 1.12.01.12.23
sylius/sylius PackagistFrom 1.12.01.12.23
sylius/sylius PackagistFrom 1.13.01.13.15
sylius/sylius PackagistFrom 1.13.01.13.15
sylius/sylius PackagistFrom 1.14.01.14.18
sylius/sylius PackagistFrom 1.14.01.14.18
sylius/sylius PackagistFrom 2.0.02.0.16
sylius/sylius PackagistFrom 2.0.02.0.16
sylius/sylius PackagistFrom 2.1.02.1.12
sylius/sylius PackagistFrom 2.1.02.1.12
sylius/sylius PackagistFrom 2.2.02.2.3
sylius/sylius PackagistFrom 2.2.02.2.3

Products include Sylius Sylius.

How do I fix CVE-2026-31824?

Upgrade sylius/sylius to a fixed version for your release line: 1.9.12, 1.10.16, 1.11.17 or 1.12.23.

Is CVE-2026-31824 being exploited?

There is no known exploitation of CVE-2026-31824 in the wild and no public exploit code.

Sources

Also known as GHSA-7mp4-25j8-hp5q.

Is CVE-2026-31824 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free