CVE-2026-31825 Sylius has a DQL Injection via API Order Filters
Attackers can inject arbitrary DQL via API order filters in Sylius, potentially reading or modifying database contents.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-31825?
CVE-2026-31825 is a medium-severity SQL injection vulnerability in Sylius, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Sylius is an Open Source eCommerce Framework on Symfony. Sylius API filters ProductPriceOrderFilter and TranslationOrderNameAndLocaleFilter pass user-supplied order direction values directly to Doctrine's orderBy() without validation. An attacker can inject arbitrary DQL. The issue is fixed in versions: 1.9.12, 1.10.16, 1.11.17, 1.12.23, 1.13.15, 1.14.18, 2.0.16, 2.1.12, 2.2.3 and above.
Which versions are affected by CVE-2026-31825?
18 open source packages ship an affected version, including sylius/sylius. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
sylius/sylius Packagist | All versions | 1.9.12 |
sylius/sylius Packagist | All versions | 1.9.12 |
sylius/sylius Packagist | From 1.10.0 | 1.10.16 |
sylius/sylius Packagist | From 1.10.0 | 1.10.16 |
sylius/sylius Packagist | From 1.11.0 | 1.11.17 |
sylius/sylius Packagist | From 1.11.0 | 1.11.17 |
12 more packages
sylius/sylius Packagist | From 1.12.0 | 1.12.23 |
sylius/sylius Packagist | From 1.12.0 | 1.12.23 |
sylius/sylius Packagist | From 1.13.0 | 1.13.15 |
sylius/sylius Packagist | From 1.13.0 | 1.13.15 |
sylius/sylius Packagist | From 1.14.0 | 1.14.18 |
sylius/sylius Packagist | From 1.14.0 | 1.14.18 |
sylius/sylius Packagist | From 2.0.0 | 2.0.16 |
sylius/sylius Packagist | From 2.0.0 | 2.0.16 |
sylius/sylius Packagist | From 2.1.0 | 2.1.12 |
sylius/sylius Packagist | From 2.1.0 | 2.1.12 |
sylius/sylius Packagist | From 2.2.0 | 2.2.3 |
sylius/sylius Packagist | From 2.2.0 | 2.2.3 |
Products include Sylius Sylius.
How do I fix CVE-2026-31825?
Upgrade sylius/sylius to a fixed version for your release line: 1.9.12, 1.10.16, 1.11.17 or 1.12.23.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2026-31825 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-31825 exists.
Other vulnerabilities in Sylius
- CVE-2026-31824 Sylius has a Promotion Usage Limit Bypass via Race Condition
- CVE-2024-57610 Denial of service in n/a
- CVE-2026-31820 Sylius affected by IDOR in Cart and Checkout LiveComponents
- CVE-2022-24743 Insufficient Session Expiration in Sylius
- CVE-2026-31819 Sylius has an Open Redirect via Referer Header
Sources
Also known as GHSA-xcwx-r2gw-w93m.