CVE-2026-31828 Parse Server has an LDAP injection via unsanitized user input in DN and group filter construction
An attacker with valid LDAP credentials can inject LDAP syntax to bypass group checks and escalate privileges in Parse Server deployments using the LDAP adapter.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-31828?
CVE-2026-31828 is a medium-severity vulnerability in Parseplatform Parse-Server, published on 10 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.13 and 8.6.26, the LDAP authentication adapter is vulnerable to LDAP injection. User-supplied input (authData.id) is interpolated directly into LDAP Distinguished Names (DN) and group search filters without escaping special characters. This allows an attacker with valid LDAP credentials to manipulate the bind DN structure and to bypass group membership checks. This enables privilege escalation from any authenticated LDAP user to a member of any restricted group. The vulnerability affects Parse Server deployments that use the LDAP authentication adapter with group-based access control. This vulnerability is fixed in 9.5.2-alpha.13 and 8.6.26.
Weakness: CWE-90
Which versions are affected by CVE-2026-31828?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.26 |
parse-server npm | All versions | 8.6.26 |
parse-server npm | From 9.0.0-alpha.1 | 9.5.2-alpha.13 |
parse-server npm | From 9.0.0-alpha.1 | 9.5.2-alpha.13 |
parse Bitnami | All versions | 8.6.26, 9.5.2 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2026-31828?
Upgrade parse-server to a fixed version for your release line: 8.6.26 or 9.5.2-alpha.13.
Is CVE-2026-31828 being exploited?
There is no known exploitation of CVE-2026-31828 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
Sources
Also known as BIT-parse-2026-31828, GHSA-7m6r-fhh7-r47c.