# CVE-2026-31828: Parse Server has an LDAP injection via unsanitized user input in DN and group filter construction

> An attacker with valid LDAP credentials can inject LDAP syntax to bypass group checks and escalate privileges in Parse Server deployments using the LDAP adapter.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 11 Mar 2026
- **Also known as:** BIT-parse-2026-31828, GHSA-7m6r-fhh7-r47c

## What is CVE-2026-31828?

CVE-2026-31828 is a medium-severity vulnerability in Parseplatform Parse-Server, published on 10 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.13 and 8.6.26, the LDAP authentication adapter is vulnerable to LDAP injection. User-supplied input (authData.id) is interpolated directly into LDAP Distinguished Names (DN) and group search filters without escaping special characters. This allows an attacker with valid LDAP credentials to manipulate the bind DN structure and to bypass group membership checks. This enables privilege escalation from any authenticated LDAP user to a member of any restricted group. The vulnerability affects Parse Server deployments that use the LDAP authentication adapter with group-based access control. This vulnerability is fixed in 9.5.2-alpha.13 and 8.6.26.

Weakness: CWE-90 (Improper Neutralization of Special Elements used in an LDAP Query)

## Which versions are affected by CVE-2026-31828?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 8.6.26 |
| `parse-server` | npm | All versions | 8.6.26 |
| `parse-server` | npm | From 9.0.0-alpha.1 | 9.5.2-alpha.13 |
| `parse-server` | npm | From 9.0.0-alpha.1 | 9.5.2-alpha.13 |
| `parse` | Bitnami | All versions | 8.6.26, 9.5.2 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2026-31828?

Upgrade parse-server to a fixed version for your release line: 8.6.26 or 9.5.2-alpha.13.

## Is CVE-2026-31828 being exploited?

There is no known exploitation of CVE-2026-31828 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31828 and fix it if it is affected.

What it is: CVE-2026-31828 is a medium-severity vulnerability in Parseplatform Parse-Server, published on 10 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-31828 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 8.6.26
- parse-server (npm): affected all versions; fixed in 8.6.26
- parse-server (npm): affected from 9.0.0-alpha.1; fixed in 9.5.2-alpha.13
- parse-server (npm): affected from 9.0.0-alpha.1; fixed in 9.5.2-alpha.13
- parse (Bitnami): affected all versions; fixed in 8.6.26, 9.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31828/ (Markdown: https://insights.sbomify.com/CVE-2026-31828/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31828
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31828
- OSV: https://osv.dev/vulnerability/CVE-2026-31828

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31828/
Summaries are generated and may contain mistakes; the official description above is the record.
