# CVE-2026-31830: sigstore-ruby verifier returns success for DSSE bundles with mismatched in-toto subject digest

> Attackers can bypass signature verification in sigstore-ruby by providing mismatched artifact digests, allowing unsigned or tampered code to appear valid.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 11 Mar 2026
- **Also known as:** GHSA-mhg6-2q2v-9h2c

## What is CVE-2026-31830?

CVE-2026-31830 is a high-severity vulnerability in sigstore-ruby, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

sigstore-ruby is a pure Ruby implementation of the sigstore verify command from the sigstore/cosign project. Prior to 0.2.3, Sigstore::Verifier#verify does not propagate the VerificationFailure returned by verify_in_toto when the artifact digest does not match the digest in the in-toto attestation subject. As a result, verification of DSSE bundles containing in-toto statements returns VerificationSuccess regardless of whether the artifact matches the attested subject. This vulnerability is fixed in 0.2.3.

Weakness: CWE-252 (Unchecked Return Value)

## Which versions are affected by CVE-2026-31830?

2 open source packages ship an affected version, including sigstore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sigstore` | RubyGems | All versions | 0.2.3 |
| `sigstore` | RubyGems | All versions | 0.2.3 |

Products: Sigstore Sigstore.

## How do I fix CVE-2026-31830?

Upgrade sigstore to 0.2.3 or later.

## Is CVE-2026-31830 being exploited?

There is no known exploitation of CVE-2026-31830 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31830 and fix it if it is affected.

What it is: CVE-2026-31830 is a high-severity vulnerability in sigstore-ruby, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-31830 in the wild and no public exploit code.

Affected packages and fixed versions:
- sigstore (RubyGems): affected all versions; fixed in 0.2.3
- sigstore (RubyGems): affected all versions; fixed in 0.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31830/ (Markdown: https://insights.sbomify.com/CVE-2026-31830/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31830
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31830
- OSV: https://osv.dev/vulnerability/CVE-2026-31830

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31830/
Summaries are generated and may contain mistakes; the official description above is the record.
