CVE-2026-31834 Umbraco Affected by Vertical Privilege Escalation via Missing Authorization Checks
Authenticated backoffice users can escalate privileges by assigning highly privileged roles due to missing authorization checks in Umbraco CMS.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-31834?
CVE-2026-31834 is a high-severity vulnerability in Umbraco Umbraco Cms, published on 10 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Umbraco is an ASP.NET CMS. From 15.3.1 to before 16.5.1 and 17.2.2, A privilege escalation vulnerability has been identified in Umbraco CMS. Under certain conditions, authenticated backoffice users with permission to manage users, may be able to elevate their privileges due to insufficient authorization enforcement when modifying user group memberships. The affected functionality does not properly validate whether a user has sufficient privileges to assign highly privileged roles. This vulnerability is fixed in 16.5.1 and 17.2.2.
Which versions are affected by CVE-2026-31834?
4 open source packages ship an affected version, including Umbraco.Cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
Umbraco.Cms NuGet | From 15.3.1 | 16.5.1 |
Umbraco.Cms NuGet | From 15.3.1 | 16.5.1 |
Umbraco.Cms NuGet | From 17.0.0 | 17.2.2 |
Umbraco.Cms NuGet | From 17.0.0 | 17.2.2 |
Products include Umbraco Umbraco Cms.
How do I fix CVE-2026-31834?
Upgrade Umbraco.Cms to a fixed version for your release line: 16.5.1 or 17.2.2.
Is CVE-2026-31834 being exploited?
There is no known exploitation of CVE-2026-31834 in the wild and no public exploit code.
Other vulnerabilities in Umbraco Umbraco Cms
- CVE-2025-67288 Umbraco CMS has an arbitrary file upload vulnerability
- CVE-2014-10074 File upload in n/a
- CVE-2012-1301 Server-side request forgery in n/a
- CVE-2012-10054 Umbraco CMS < 4.7.1 codeEditorSave.asmx RCE
- CVE-2025-32017 Umbraco has a Management API Vulnerability to Path Traversal With Authenticated Users
Sources
Also known as GHSA-rhcg-3h8r-v6vp.