# CVE-2026-31839: Striae has a hash validation utility vulnerability

> Attackers can bypass integrity checks in Striae by modifying manifest hashes alongside package content, allowing tampered confirmation packages to pass validation.

- **Severity:** High 8.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Mar 2026
- **Updated:** 11 Mar 2026
- **Also known as:** GHSA-mmf8-487q-p45m

## What is CVE-2026-31839?

CVE-2026-31839 is a high-severity vulnerability in striae-org striae, published on 11 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Striae is a firearms examiner's comparison companion. A high-severity integrity bypass vulnerability existed in Striae's digital confirmation workflow prior to v3.0.0. Hash-only validation trusted manifest hash fields that could be modified together with package content, allowing tampered confirmation packages to pass integrity checks. This vulnerability is fixed in 3.0.0.

Weakness: CWE-354 (Improper Validation of Integrity Check Value)

## Which versions are affected by CVE-2026-31839?

2 open source packages ship an affected version, including @striae-org/striae. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@striae-org/striae` | npm | From 0.9.22-0 | 3.0.0 |
| `@striae-org/striae` | npm | From 0.9.22-0 | 3.0.0 |

Products: Striae Striae.

## How do I fix CVE-2026-31839?

Upgrade @striae-org/striae to 3.0.0 or later.

## Is CVE-2026-31839 being exploited?

There is no known exploitation of CVE-2026-31839 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31839 and fix it if it is affected.

What it is: CVE-2026-31839 is a high-severity vulnerability in striae-org striae, published on 11 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-31839 in the wild and no public exploit code.

Affected packages and fixed versions:
- @striae-org/striae (npm): affected from 0.9.22-0; fixed in 3.0.0
- @striae-org/striae (npm): affected from 0.9.22-0; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31839/ (Markdown: https://insights.sbomify.com/CVE-2026-31839/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31839
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31839
- OSV: https://osv.dev/vulnerability/CVE-2026-31839

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31839/
Summaries are generated and may contain mistakes; the official description above is the record.
