{"answers":{"affected":"2 open source packages ship an affected version, including hyperterse. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-31841 in the wild and no public exploit code.","fix":"Upgrade hyperterse to 2.2.0 or later.","what":"CVE-2026-31841 is a medium-severity vulnerability in hyperterse, published on 12 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-31841 and fix it if it is affected.\n\nWhat it is: CVE-2026-31841 is a medium-severity vulnerability in hyperterse, published on 12 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-31841 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- hyperterse (npm): affected from 2.0.0; fixed in 2.2.0\n- hyperterse (npm): affected from 2.0.0; fixed in 2.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-31841/ (Markdown: https://insights.sbomify.com/CVE-2026-31841/index.md)","id":"CVE-2026-31841","markdown":"https://insights.sbomify.com/CVE-2026-31841/index.md","name":"CVE-2026-31841","record":{"aliases":["GHSA-92gp-jfgx-9qpv"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"MCP framework library","requires_auth":"none","summary":"Attackers can view raw SQL queries via the search tool, exposing internal database statements that should remain hidden.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"hyperterse","vendor":"hyperterse"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-433","name":"Unparsed Raw Web Content Delivery"}],"description":"Hyperterse is a tool-first MCP framework for building AI-ready backend surfaces from declarative config. Prior to v2.2.0, the search tool allows LLMs to search for tools using natural language. While returning results, Hyperterse also returned the raw SQL queries, exposing statements which were supposed to be executed under the hood, and protected from being displayed publicly. This issue has been fixed as of v2.2.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Raw exposure of database statements in Hyperterse MCP search tool","id":"CVE-2026-31841","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Tinyproxy HTTP request parsing desynchronization via case-sensitive Transfer-Encoding handling","id":"CVE-2026-31842"},"packages":[{"ecosystem":"npm","fixed":["2.2.0"],"introduced":["2.0.0"],"last_affected":[],"package":"hyperterse","purl":null,"source":"GHSA-92gp-jfgx-9qpv"},{"ecosystem":"npm","fixed":["2.2.0"],"introduced":["2.0.0"],"last_affected":[],"package":"hyperterse","purl":"pkg:npm/hyperterse","source":"GHSA-92gp-jfgx-9qpv"}],"prev":{"headline":"Parse Server has a SQL injection via dot-notation field name in PostgreSQL","id":"CVE-2026-31840"},"products":["hyperterse"],"published":"2026-03-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-12","vendors":["hyperterse"]},"summary":"Attackers can view raw SQL queries via the search tool, exposing internal database statements that should remain hidden.","url":"https://insights.sbomify.com/CVE-2026-31841/"}