{"answers":{"affected":"2 open source packages ship an affected version, including goodoneuz/pay-uz.","exploited":"There is no known exploitation of CVE-2026-31843 in the wild and no public exploit code.","fix":"Upgrade goodoneuz/pay-uz to 3.0.0 or later.","what":"CVE-2026-31843 is a critical missing authorization vulnerability in goodoneuz pay-uz, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-31843 and fix it if it is affected.\n\nWhat it is: CVE-2026-31843 is a critical missing authorization vulnerability in goodoneuz pay-uz, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-31843 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- goodoneuz/pay-uz (Packagist): affected all versions; fixed in 3.0.0\n- goodoneuz/pay-uz (Packagist): affected all versions; fixed in 3.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-31843/ (Markdown: https://insights.sbomify.com/CVE-2026-31843/index.md)","id":"CVE-2026-31843","markdown":"https://insights.sbomify.com/CVE-2026-31843/index.md","name":"CVE-2026-31843","record":{"aliases":["GHSA-m5wg-cjgh-223j"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Laravel payment package","requires_auth":"none","summary":"Unauthenticated attackers can overwrite PHP files via an unprotected API endpoint, leading to remote code execution in the pay-uz Laravel package.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"TuranSec","cpe":[],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"The goodoneuz/pay-uz Laravel package (\u003c= 2.2.24) contains a critical vulnerability in the /payment/api/editable/update endpoint that allows unauthenticated attackers to overwrite existing PHP payment hook files. The endpoint is exposed via Route::any without authentication middleware, enabling remote access without credentials.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"goodoneuz/pay-uz Unauthenticated PHP File Overwrite via /payment/api/editable/update Leading to Remote Code Execution","id":"CVE-2026-31843","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"Authenticated SQL Injection in Koha displayby parameter of suggestion.pl","id":"CVE-2026-31844"},"packages":[{"ecosystem":"Packagist","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"goodoneuz/pay-uz","purl":null,"source":"GHSA-m5wg-cjgh-223j"},{"ecosystem":"Packagist","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"goodoneuz/pay-uz","purl":"pkg:composer/goodoneuz/pay-uz","source":"GHSA-m5wg-cjgh-223j"}],"prev":{"headline":"Tinyproxy HTTP request parsing desynchronization via case-sensitive Transfer-Encoding handling","id":"CVE-2026-31842"},"products":["pay-uz"],"published":"2026-04-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-10","vendors":["goodoneuz"]},"summary":"Unauthenticated attackers can overwrite PHP files via an unprotected API endpoint, leading to remote code execution in the pay-uz Laravel package.","url":"https://insights.sbomify.com/CVE-2026-31843/"}