# CVE-2026-31857: CraftCMS has an RCE vulnerability via relational conditionals in the control panel

> Authenticated Craft CMS users can achieve remote code execution via unsandboxed Twig rendering in condition rules, bypassing security settings.

- **Severity:** High 8.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2026
- **Updated:** 12 Mar 2026
- **Also known as:** GHSA-fp5j-j7j4-mcxc

## What is CVE-2026-31857?

CVE-2026-31857 is a high-severity code injection vulnerability in Craftcms Craft Cms, published on 11 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Craft is a content management system (CMS). Prior to 5.9.9 and 4.17.4, a Remote Code Execution vulnerability exists in the Craft CMS 5 conditions system. The BaseElementSelectConditionRule::getElementIds() method passes user-controlled string input through renderObjectTemplate() -- an unsandboxed Twig rendering function with escaping disabled. Any authenticated Control Panel user (including non-admin roles such as Author or Editor) can achieve full RCE by sending a crafted condition rule via standard element listing endpoints. This vulnerability requires no admin privileges, no special permissions beyond basic control panel access, and bypasses all production hardening settings (allowAdminChanges: false, devMode: false, enableTwigSandbox: true). Users should update to the patched 5.9.9 or 4.17.4 release to mitigate the issue.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-31857?

4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.0.0-beta.1 | 4.17.4 |
| `craftcms/cms` | Packagist | From 4.0.0-beta.1 | 4.17.4 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.9.9 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.9.9 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2026-31857?

Upgrade craftcms/cms to a fixed version for your release line: 4.17.4 or 5.9.9.

## Is CVE-2026-31857 being exploited?

There is no known exploitation of CVE-2026-31857 in the wild and no public exploit code.

Public exploit code:

- CraftCMS has an RCE vulnerability via relational conditionals in the control panel (github_poc): https://github.com/0Asylum/CVE-2026-31857
- Proof of Concept for CVE-2026-31857, an authenticated Remote Code Execution vulnerability in Craft CMS caused by unsafe processing of user-controlled Twig expressions. (github_poc): https://github.com/kaizoku73/CVE-2026-31857-PoC
- https://github.com/TRX-0/CVE-2026-31857-craftcms-ssti (github_poc): https://github.com/TRX-0/CVE-2026-31857-craftcms-ssti
- Craft CMS RCE via relational conditionals in the control panel (github_poc): https://github.com/0xTatsuki/CVE-2026-31857
- CVE-2026-31857 - Craft CMS authenticated RCE timing verifier. (github_poc): https://github.com/WhiteMachin3/CVE-2026-31857

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31857 and fix it if it is affected.

What it is: CVE-2026-31857 is a high-severity code injection vulnerability in Craftcms Craft Cms, published on 11 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-31857 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.0.0-beta.1; fixed in 4.17.4
- craftcms/cms (Packagist): affected from 4.0.0-beta.1; fixed in 4.17.4
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.9.9
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.9.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31857/ (Markdown: https://insights.sbomify.com/CVE-2026-31857/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31857
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31857
- OSV: https://osv.dev/vulnerability/CVE-2026-31857

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31857/
Summaries are generated and may contain mistakes; the official description above is the record.
