# CVE-2026-31860: Unhead has a XSS bypass in `useHeadSafe` via attribute name injection and case-sensitive protocol check

> Attackers can bypass XSS protections in Unhead to inject malicious HTML attributes into server-side rendered pages, potentially executing arbitrary scripts.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Mar 2026
- **Updated:** 13 Mar 2026
- **Also known as:** GHSA-g5xx-pwrp-g3fv

## What is CVE-2026-31860?

CVE-2026-31860 is a medium-severity cross-site scripting vulnerability in unjs unhead, published on 12 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Unhead is a document head and template manager. Prior to 2.1.11, useHeadSafe() can be bypassed to inject arbitrary HTML attributes, including event handlers, into SSR-rendered <head> tags. This is the composable that Nuxt docs recommend for safely handling user-generated content. The acceptDataAttrs function (safe.ts, line 16-20) allows any property key starting with data- through to the final HTML. It only checks the prefix, not whether the key contains spaces or other characters that break HTML attribute parsing. This vulnerability is fixed in 2.1.11.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-31860?

2 open source packages ship an affected version, including unhead. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `unhead` | npm | All versions | 2.1.11 |
| `unhead` | npm | All versions | 2.1.11 |

Products: Unjs Unhead.

## How do I fix CVE-2026-31860?

Upgrade unhead to 2.1.11 or later.

## Is CVE-2026-31860 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-31860 exists.

## Other vulnerabilities in unjs unhead

- [CVE-2026-39315](https://insights.sbomify.com/CVE-2026-39315/): Unhead has a hasDangerousProtocol() bypass via leading-zero padded HTML entities in useHeadSafe() (medium 6.1)
- [CVE-2026-31873](https://insights.sbomify.com/CVE-2026-31873/): Unhead has a Bypass of URI Scheme Sanitization in makeTagSafe via Case-Sensitivity (not scored)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-31860 and fix it if it is affected.

What it is: CVE-2026-31860 is a medium-severity cross-site scripting vulnerability in unjs unhead, published on 12 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-31860 exists.

Affected packages and fixed versions:
- unhead (npm): affected all versions; fixed in 2.1.11
- unhead (npm): affected all versions; fixed in 2.1.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-31860/ (Markdown: https://insights.sbomify.com/CVE-2026-31860/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-31860
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-31860
- OSV: https://osv.dev/vulnerability/CVE-2026-31860

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-31860/
Summaries are generated and may contain mistakes; the official description above is the record.
